[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20070225194817.GB1746@elf.ucw.cz>
Date: Sun, 25 Feb 2007 20:48:17 +0100
From: Pavel Machek <pavel@....cz>
To: "Eric W. Biederman" <ebiederm@...ssion.com>
Cc: Andrew Morton <akpm@...l.org>, linux-kernel@...r.kernel.org,
Zwane Mwaikambo <zwane@...radead.org>,
Ashok Raj <ashok.raj@...el.com>, Ingo Molnar <mingo@...e.hu>,
"Lu, Yinghai" <yinghai.lu@....com>,
Natalie Protasevich <protasnb@...il.com>,
Andi Kleen <ak@...e.de>,
"Siddha, Suresh B" <suresh.b.siddha@...el.com>,
Linus Torvalds <torvalds@...ux-foundation.org>
Subject: Re: [PATCH 12/14] x86_64 irq: Add constants for the reserved IRQ vectors.
On Sun 2007-02-25 04:15:30, Eric W. Biederman wrote:
> Pavel Machek <pavel@....cz> writes:
>
> > Hi!
> >
> >> For the ISA irqs we reserve 16 vectors. This patch adds constants for
> >> those vectors and modifies the code to use them. Making the code a
> >> little clearer and making it possible to move these vectors in the future.
> >
> >
> >> /*
> >> * Vectors 0x20-0x2f are used for ISA interrupts.
> >> */
> >> +#define IRQ0_VECTOR FIRST_EXTERNAL_VECTOR
> >> +#define IRQ1_VECTOR IRQ0_VECTOR + 1
> >
> > Maybe IRQ_VECTOR(1) would be similary readable, and would avoid
> >
> >> +#define IRQ2_VECTOR IRQ0_VECTOR + 2
> >> +#define IRQ3_VECTOR IRQ0_VECTOR + 3
> >> +#define IRQ4_VECTOR IRQ0_VECTOR + 4
> >> +#define IRQ5_VECTOR IRQ0_VECTOR + 5
> >> +#define IRQ6_VECTOR IRQ0_VECTOR + 6
> >> +#define IRQ7_VECTOR IRQ0_VECTOR + 7
> >> +#define IRQ8_VECTOR IRQ0_VECTOR + 8
> >> +#define IRQ9_VECTOR IRQ0_VECTOR + 9
> >> +#define IRQ10_VECTOR IRQ0_VECTOR + 10
> >> +#define IRQ11_VECTOR IRQ0_VECTOR + 11
> >> +#define IRQ12_VECTOR IRQ0_VECTOR + 12
> >> +#define IRQ13_VECTOR IRQ0_VECTOR + 13
> >> +#define IRQ14_VECTOR IRQ0_VECTOR + 14
> >> +#define IRQ15_VECTOR IRQ0_VECTOR + 15
> >
> > ...these defines?
>
> It would, and mostly I like it. However, of the 1500+ possible irqs
> exactly 16 have a reserved vector. IRQ_VECTOR(N) does not convey
> that in fact it conveys the opposite impression.
>
> So I think the code is more maintainable with the distinct
> definitions.
BUILD_BUG_ON(x > 15) ? ;-).
Pavel
--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists