[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20070308102105.GA21119@infradead.org>
Date: Thu, 8 Mar 2007 10:21:05 +0000
From: Christoph Hellwig <hch@...radead.org>
To: Eric Dumazet <dada1@...mosbay.com>
Cc: Christoph Hellwig <hch@...radead.org>,
Linus Torvalds <torvalds@...ux-foundation.org>,
Davide Libenzi <davidel@...ilserver.org>,
Avi Kivity <avi@...o.co.il>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Andrew Morton <akpm@...ux-foundation.org>,
Al Viro <viro@...iv.linux.org.uk>
Subject: Re: [patch] epoll use a single inode ...
On Thu, Mar 08, 2007 at 10:42:21AM +0100, Eric Dumazet wrote:
> @@ -1823,6 +1823,9 @@ char * d_path(struct dentry *dentry, str
> struct vfsmount *rootmnt;
> struct dentry *root;
>
> + if (dentry->d_op && dentry->d_op->d_dname)
> + return (dentry->d_op->d_dname)(dentry, buf, buflen);
Please don't put braces around the function pointer call. Also I
think we really want a comment here why we need this call.
> +static char * pipefs_dname(struct dentry *dentry, char *buffer, int buflen)
normally this would be:
static char *pipefs_dname(struct dentry *dentry, char *buffer, int buflen)
> +static char * sockfs_dname(struct dentry *dentry, char *buffer, int buflen)
same here.
> - char name[32];
>
> - this.len = sprintf(name, "[%lu]", SOCK_INODE(sock)->i_ino);
> - this.name = name;
> + this.len = 0;
> + this.name = "";
> this.hash = 0;
Can you add a helper to init this one?
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists