[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <46018364.1050501@redhat.com>
Date: Wed, 21 Mar 2007 15:11:32 -0400
From: Rik van Riel <riel@...hat.com>
To: Matt Mackall <mpm@...enic.com>
CC: Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
linux-mm <linux-mm@...ck.org>
Subject: Re: [RFC][PATCH] split file and anonymous page queues #3
Matt Mackall wrote:
> On Tue, Mar 20, 2007 at 06:08:10PM -0400, Rik van Riel wrote:
>> - "Active: %8lu kB\n"
>> - "Inactive: %8lu kB\n"
> ...
>> + "Active(anon): %8lu kB\n"
>> + "Inactive(anon): %8lu kB\n"
>> + "Active(file): %8lu kB\n"
>> + "Inactive(file): %8lu kB\n"
>
> Potentially incompatible change. How about preserving the original
> fields (by totalling), then adding the other fields in a second patch.
Fixed in the attached patch.
>> if (!pagevec_add(&lru_pvec, page))
>> - __pagevec_lru_add(&lru_pvec);
>> + __pagevec_lru_add_file(&lru_pvec);
>
> Wouldn't lru_file_add or file_lru_add be a better name? If the object
> is a "file lru" then sticking "add" in the middle is a little ugly.
Not sure about this one. Does anybody else have an opinion here?
>> spin_lock_irq(&zone->lru_lock);
>> if (PageLRU(page) && !PageActive(page)) {
>> - del_page_from_inactive_list(zone, page);
>> + if (page_anon(page)) {
>> + del_page_from_inactive_anon_list(zone,page);
>> SetPageActive(page);
>> - add_page_to_active_list(zone, page);
>> + add_page_to_active_anon_list(zone, page);
>> + } else {
>> + del_page_from_inactive_file_list(zone, page);
>> + SetPageActive(page);
>> + add_page_to_active_file_list(zone, page);
>> + }
>> __count_vm_event(PGACTIVATE);
>> }
>
> Missing a level of indentation.
Fixed.
--
All Rights Reversed
View attachment "linux-2.6-vm-split.patch" of type "text/x-patch" (51588 bytes)
Powered by blists - more mailing lists