[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20070423131720.GE25144@in.ibm.com>
Date: Mon, 23 Apr 2007 18:47:20 +0530
From: Gautham R Shenoy <ego@...ibm.com>
To: "Rafael J. Wysocki" <rjw@...k.pl>
Cc: Andrew Morton <akpm@...ux-foundation.org>,
Ingo Molnar <mingo@...e.hu>, Oleg Nesterov <oleg@...sign.ru>,
linux-kernel@...r.kernel.org, vatsa@...ibm.com, paulmck@...ibm.com,
pavel@....cz
Subject: Re: [RFC][PATCH -mm 2/3] freezer: Introduce freezer_flags
On Sun, Apr 22, 2007 at 09:39:26PM +0200, Rafael J. Wysocki wrote:
> @@ -63,9 +100,9 @@ static inline int thaw_process(struct ta
> */
> static inline void frozen_process(struct task_struct *p)
> {
> - p->flags |= PF_FROZEN;
> + set_frozen_flag(p);
> wmb();
> - clear_tsk_thread_flag(p, TIF_FREEZE);
> + do_not_freeze(p);
We may want to rename do_not_freeze to something else. It kind of
looks weird calling do_not_freeze(p) after setting the frozen flag!
Probably, just a matter of taste :-)
> }
>
Thanks and Regards
gautham.
--
Gautham R Shenoy
Linux Technology Center
IBM India.
"Freedom comes with a price tag of responsibility, which is still a bargain,
because Freedom is priceless!"
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists