[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <200704232157.20232.rjw@sisk.pl>
Date: Mon, 23 Apr 2007 21:57:19 +0200
From: "Rafael J. Wysocki" <rjw@...k.pl>
To: ego@...ibm.com
Cc: Andrew Morton <akpm@...ux-foundation.org>,
Ingo Molnar <mingo@...e.hu>, Oleg Nesterov <oleg@...sign.ru>,
linux-kernel@...r.kernel.org, vatsa@...ibm.com, paulmck@...ibm.com,
pavel@....cz
Subject: Re: [RFC][PATCH -mm 2/3] freezer: Introduce freezer_flags
On Monday, 23 April 2007 15:17, Gautham R Shenoy wrote:
> On Sun, Apr 22, 2007 at 09:39:26PM +0200, Rafael J. Wysocki wrote:
> > @@ -63,9 +100,9 @@ static inline int thaw_process(struct ta
> > */
> > static inline void frozen_process(struct task_struct *p)
> > {
> > - p->flags |= PF_FROZEN;
> > + set_frozen_flag(p);
> > wmb();
> > - clear_tsk_thread_flag(p, TIF_FREEZE);
> > + do_not_freeze(p);
>
> We may want to rename do_not_freeze to something else. It kind of
> looks weird calling do_not_freeze(p) after setting the frozen flag!
>
> Probably, just a matter of taste :-)
Hmm, I wanted to avoid changing the existing names in this patch, but in this
particular case you are obviously right. I'll change that to
clear_freeze_flag().
Greetings,
Rafael
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists