lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 1 May 2007 19:51:46 +0200 (CEST)
From:	Geert Uytterhoeven <geert@...ux-m68k.org>
To:	Linus Torvalds <torvalds@...ux-foundation.org>
Cc:	David Howells <dhowells@...hat.com>,
	Andrew Morton <akpm@...ux-foundation.org>,
	Linux Kernel Development <linux-kernel@...r.kernel.org>
Subject: Re: [AF_RXRPC]: Make the in-kernel AFS filesystem use AF_RXRPC.

On Tue, 1 May 2007, Linus Torvalds wrote:
> On Tue, 1 May 2007, Geert Uytterhoeven wrote:
> > This causes a compile failure on m68k:
> > 
> > | linux/fs/afs/fsclient.c: In function 'afs_deliver_fs_fetch_data':
> > | linux/fs/afs/fsclient.c:269: warning: dereferencing 'void *' pointer
> > | linux/fs/afs/fsclient.c:269: error: request for member 'virtual' in something not a structure or union
> > 
> > Probably you wanted to assign call->reply3 to a struct page pointer first, like you do for the call->unmarshall == 2 case.
> 
> Hmm. Wouldn't it be nicer to make "kmap_atomic()" be an inline function 
> instead? That way, if you pass it a "void *", it still just works, and you 
> get a much nicer/more readable error message too when the types actually 
> don't match?

Of course.

> Of course, there may be some reason why <linux/highmem.h> does those with 
> #define's rather than inline functions. Maybe "page_address()" or 
> "pagefault_disabled()" is not declared at that point, and asking it to be 
> declared might cause header file inclusion recursion?

That's what I was afraid of, too...

However, this change seems to build fine (for one of my test configs):

Convert kmap_atomic() in the non-highmem case from a macro to a static
inline function, for better type-checking and the ability to pass void
pointers instead of struct page pointers.

Signed-off-by: Geert Uytterhoeven <geert@...ux-m68k.org>

--- linux-m68k-2.6.21/include/linux/highmem.h
+++ linux-m68k-2.6.21/include/linux/highmem.h
@@ -42,8 +42,14 @@ static inline void *kmap(struct page *pa
 
 #define kunmap(page) do { (void) (page); } while (0)
 
-#define kmap_atomic(page, idx) \
-	({ pagefault_disable(); page_address(page); })
+#include <asm/kmap_types.h>
+
+static inline void *kmap_atomic(struct page *page, enum km_type idx)
+{
+	pagefault_disable();
+	return page_address(page);
+}
+
 #define kunmap_atomic(addr, idx)	do { pagefault_enable(); } while (0)
 #define kmap_atomic_pfn(pfn, idx)	kmap_atomic(pfn_to_page(pfn), (idx))
 #define kmap_atomic_to_page(ptr)	virt_to_page(ptr)

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@...ux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ