[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <m1odkvi57e.fsf@ebiederm.dsl.xmission.com>
Date: Tue, 08 May 2007 11:40:53 -0600
From: ebiederm@...ssion.com (Eric W. Biederman)
To: "Satyam Sharma" <satyam.sharma@...il.com>
Cc: "Pekka Enberg" <penberg@...helsinki.fi>,
"Michael Tokarev" <mjt@....msk.ru>,
"Shani Moideen" <shani.moideen@...ro.com>, ebiederm@...ssion.com,
linux-kernel@...r.kernel.org, kernel-janitors@...ts.osdl.org
Subject: Re: [KJ PATCH] Replacing memset(<addr>,0,PAGE_SIZE) with clear_page() in kernel/kexec.c
"Satyam Sharma" <satyam.sharma@...il.com> writes:
> On 5/8/07, Pekka Enberg <penberg@...helsinki.fi> wrote:
>> Shani Moideen wrote:
>> > > ptr = kmap(page);
>> > > - memset(ptr, 0, PAGE_SIZE);
>> > > + clear_page(ptr);
>>
>> On 5/8/07, Michael Tokarev <mjt@....msk.ru> wrote:
>> > I wonder if it's worth to invent kzmap() or something like that... ;)
>>
>> I am counting 59 kmap + memset pairs in the kernel, so perhaps it is
>> worth it to reduce kernel text size.
>
> Stuff of the sort already exists. Look for clear_highpage(),
> clear_user_highpage() and memclear_highpage_flush (recently renamed to
> zero_user_page, see -mm). But they all use kmap_atomic() -- kmap()
> variants would have to be added. Also, they're all inlines, so I'm not
> sure you'd be able to cut down text size, but still getting rid of
> open-coding is always good.
In this instance a clear_page variant should be ok. The combined
variants are likely not because I use the mapping after it is cleared.
Eric
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists