[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1070508042929.28767@suse.de>
Date: Tue, 8 May 2007 14:29:29 +1000
From: NeilBrown <neilb@...e.de>
To: Andrew Morton <akpm@...ux-foundation.org>
Cc: Neil Brown <neilb@...e.de>
Subject: [PATCH 003 of 5] md: Remove the slash from the name of a kmem_cache used by raid5.
SLUB doesn't like slashes as it wants to use the cache name
as the name of a directory (or symlink) in sysfs.
Signed-off-by: Neil Brown <neilb@...e.de>
### Diffstat output
./drivers/md/raid5.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff .prev/drivers/md/raid5.c ./drivers/md/raid5.c
--- .prev/drivers/md/raid5.c 2007-05-07 14:36:01.000000000 +1000
+++ ./drivers/md/raid5.c 2007-05-07 15:08:45.000000000 +1000
@@ -931,8 +931,8 @@ static int grow_stripes(raid5_conf_t *co
struct kmem_cache *sc;
int devs = conf->raid_disks;
- sprintf(conf->cache_name[0], "raid5/%s", mdname(conf->mddev));
- sprintf(conf->cache_name[1], "raid5/%s-alt", mdname(conf->mddev));
+ sprintf(conf->cache_name[0], "raid5-%s", mdname(conf->mddev));
+ sprintf(conf->cache_name[1], "raid5-%s-alt", mdname(conf->mddev));
conf->active_name = 0;
sc = kmem_cache_create(conf->cache_name[conf->active_name],
sizeof(struct stripe_head)+(devs-1)*sizeof(struct r5dev),
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists