lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Sat, 19 May 2007 18:20:09 +0530 (IST)
From:	"Vasantha Kumar Puttappa" <vasanthakumar@...b.ac.in>
To:	linux-kernel@...r.kernel.org
Cc:	vasanthakumar@...b.ac.in
Subject: Packets lost: Softirq

Hi All,
 Please somebody guide me here. I desparatley need help regarding this
issue. ( plz do "reply to all")

 I am tracking all udp packets (in particular, SIP based UDP packets)that
goes through the iptables using LOG mechanism.
 I use the following command,
     iptables -A INPUT -p udp -j LOG --log-level-4.
     iptables -A FORWARD -p udp -j LOG --log-level-4

  In addition, i also run 'Ethereal' to make sure that all the packets
captured goes through the iptables as well.

  Here is the problem,
    Sometimes, a random number of packets doesnot go through IPtables and
  they are completely lost. Although, I can see those lost packets in
Ethereal. I tried increasing the backlog queue and ip_queue length, but
still no use.

   I am using Netgear's wireless network card (WG511, made in taiwan).
   Device driver: Prism54
   firmware: isl3890
   Kernel verison-- 2.6.11-6mdk

  Let me give you more insight into what I am trying do.

 I have a vitrual network interface and 2 physical network interface (one
Ethernet based, and other 802.11 based). The virtual network interface
dynamically binds to any one of the above physical interfaces for packet
transmission. The issue of packet loss occurs **only** during link
switching.

I feel that the following issues might be the possible reasons for the
packet loss.

1. Due to missing soft_IRQ interrupt for packets and hence packet loss ( i
have no proof to back this)
2. Due to incompatible wireless device driver.

Somebody please guide me. How do I findout the cause of this.

 Thank you,

  Regards
  Vasanth





-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists