[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <84144f020705210426w1704e133k2559f8ceffe9268c@mail.gmail.com>
Date: Mon, 21 May 2007 14:26:01 +0300
From: "Pekka Enberg" <penberg@...helsinki.fi>
To: "Bryan Wu" <bryan.wu@...log.com>
Cc: torvalds@...ux-foundation.org, akpm@...ux-foundation.org,
linux-kernel@...r.kernel.org, "Aubrey Li" <aubrey.li@...log.com>
Subject: Re: [PATCH 20/32] Blackfin arch: dma_memcpy borken for > 64K
Hi Bryan,
On 5/21/07, Bryan Wu <bryan.wu@...log.com> wrote:
> -void *dma_memcpy(void *dest, const void *src, size_t size)
> +void *_dma_memcpy(void *dest, const void *src, size_t size)
Minor nitpick: the established naming convention is two underscores, not one.
> +void *dma_memcpy(void *dest, const void *src, size_t size)
> +{
> + size_t bulk;
> + size_t rest;
> + void * addr;
> +
> + bulk = (size >> 16) << 16;
I assume this is significantly faster on your architecture than:
bulk = size & ~0xFFFFUL;
which is more readable?
> + rest = size - bulk;
> + if (bulk)
> + _dma_memcpy(dest, src, bulk);
> + addr = _dma_memcpy(dest+bulk, src+bulk, rest);
> + return addr;
Does this work for 128K and up? Why?
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists