[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <46559638.6@qumranet.com>
Date: Thu, 24 May 2007 16:42:16 +0300
From: Avi Kivity <avi@...ranet.com>
To: Heiko Carstens <heiko.carstens@...ibm.com>
CC: kvm-devel@...ts.sourceforge.net, linux-kernel@...r.kernel.org,
lhcs-devel@...ts.sourceforge.net
Subject: Re: [kvm-devel] [PATCH 4/7] SMP: Implement on_one_cpu()
Heiko Carstens wrote:
> On Thu, May 24, 2007 at 03:10:12PM +0300, Avi Kivity wrote:
>
>> This defines on_one_cpu() which is similar to smp_call_function_single()
>> except that it works if cpu happens to be the current cpu. Can also be
>> seen as a complement to on_each_cpu() (which also doesn't treat the
>> current cpu specially).
>>
>> Signed-off-by: Avi Kivity <avi@...ranet.com>
>> ---
>> include/linux/smp.h | 15 +++++++++++++++
>> kernel/softirq.c | 24 ++++++++++++++++++++++++
>> 2 files changed, 39 insertions(+), 0 deletions(-)
>>
>> +/*
>> + * Call a function on one processor
>> + */
>> +int on_one_cpu(int cpu, void (*func)(void *info), void *info,
>> + int retry, int wait);
>>
>>
>
> Would you mind renaming that one to simply 'on_cpu'? It's even shorter and
> clearly everybody will know what its purpose is. Also I doubt we will ever
> have something like 'on_two_cpus'.
>
That was my first choice, but then I went for symmetry with
on_each_cpu(). I'll rename it to on_cpu() unless there are objections.
--
error compiling committee.c: too many arguments to function
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists