[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Pine.LNX.4.61.0705262121150.7344@yvahk01.tjqt.qr>
Date: Sat, 26 May 2007 21:27:45 +0200 (MEST)
From: Jan Engelhardt <jengelh@...ux01.gwdg.de>
To: Auke Kok <auke-jan.h.kok@...el.com>
cc: randy.dunlap@...cle.com, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/2] [condingstyle] Add chapter on tests
On May 25 2007 10:25, Auke Kok wrote:
>diff --git a/Documentation/CodingStyle b/Documentation/CodingStyle
>index f518395..3635b38 100644
>--- a/Documentation/CodingStyle
>+++ b/Documentation/CodingStyle
>@@ -393,7 +393,7 @@ int fun(int a)
> int result = 0;
> char *buffer = kmalloc(SIZE);
>
>- if (buffer == NULL)
>+ if (!buffer)
> return -ENOMEM;
Please don't do this. With ==NULL/!=NULL, it is clear what
<randomvariable> could be (integer or pointer) without needing
to look it up. It also reads quite strange: "if not buffer".
For bools ('adjectives' / 'is a'), it works, not so much for ptrs.
Hence:
>+If you give your variables and pointers good names, there is never a need
>+to compare the value stored in that variable to NULL or true/false, so
>+omit all that and keep it short.
>+ ptr = s->next;
>+ if (!ptr)
>+ return;
Not agreed.
>+
>+ v = (read_byte(register));
>+ if (v & mask)
>+ return;
well, yes.
>+ if (is_prime(number))
Yes.
And I'd also like to mention one rather special case where I'd rather
like to see ==0 than ! for clarity (!strcmp looks like !streq, so
one needs to look twice to get it):
if (!strcmp(hay, needle))
At least don't force the '!' doctrine.
Jan
--
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists