[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20070530135432.19422e01@gondolin.boeblingen.de.ibm.com>
Date: Wed, 30 May 2007 13:54:32 +0200
From: Cornelia Huck <cornelia.huck@...ibm.com>
To: Tejun Heo <htejun@...il.com>
Cc: gregkh@...e.de, dmitry.torokhov@...il.com, oneukum@...e.de,
rpurdie@...ys.net, stern@...land.harvard.edu, maneesh@...ibm.com,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/6] sysfs: implement sysfs flags and SYSFS_FLAG_REMOVED
On Tue, 29 May 2007 01:36:26 +0900,
Tejun Heo <htejun@...il.com> wrote:
> Rename sysfs_dirent->s_type to s_flags, pack type into lower eight
> bits and use the rest for flags. sysfs_type() can used to access the
> type. This patch also implements SYSFS_FLAG_REMOVED which is used to
> improve sanity check in sysfs_deactivate(). The flag will also be
> used to make directory entries reclamiable.
>
> Signed-off-by: Tejun Heo <htejun@...il.com>
> ---
> fs/sysfs/dir.c | 37 +++++++++++++++++++++++--------------
> fs/sysfs/inode.c | 5 +++--
> fs/sysfs/mount.c | 2 +-
> fs/sysfs/sysfs.h | 7 ++++++-
> include/linux/sysfs.h | 4 ++++
> 5 files changed, 37 insertions(+), 18 deletions(-)
This seems sane, but I'd split this into two patches: One introducing
sysfs_type(), and one adding SYSFS_FLAG_REMOVED.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists