[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20070605203048.GR31565@havoc.gtf.org>
Date: Tue, 5 Jun 2007 16:30:48 -0400
From: Jeff Garzik <jeff@...zik.org>
To: "Keshavamurthy, Anil S" <anil.s.keshavamurthy@...el.com>
Cc: linux-kernel@...r.kernel.org, akpm@...l.org, ak@...e.de,
gregkh@...e.de, muli@...ibm.com, asit.k.mallick@...el.com,
suresh.b.siddha@...el.com, arjan@...ux.intel.com,
ashok.raj@...el.com, shaohua.li@...el.com, davem@...emloft.net
Subject: Re: [Intel-IOMMU 02/10] Library routines for handling pre-allocated pool of objects
On Tue, Jun 05, 2007 at 01:24:33PM -0700, Keshavamurthy, Anil S wrote:
> 1 file changed, 65 insertions(+), 19 deletions(-)
>
> Index: linux-2.6.22-rc3/lib/respool.c
> ===================================================================
> --- linux-2.6.22-rc3.orig/lib/respool.c 2007-06-05 12:22:26.000000000 -0700
> +++ linux-2.6.22-rc3/lib/respool.c 2007-06-05 12:58:01.000000000 -0700
> @@ -67,6 +67,7 @@
> {
> unsigned long flags;
> struct list_head *plist = (struct list_head *)vaddr;
> + bool queue_work = 0;
Seems sane to me.
I only have a very minor nit to pick: naming a variable (queue_work)
the same as a public function may cause confusion.
Also, if its a bool you should initialize it to 'true' or 'false'.
Jeff
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists