[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <468E9E0E.1050705@vmware.com>
Date: Fri, 06 Jul 2007 12:54:54 -0700
From: Zachary Amsden <zach@...are.com>
To: Stefan Richter <stefanr@...6.in-berlin.de>
CC: "Robert P. J. Day" <rpjday@...dspring.com>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Andrew Morton <akpm@...l.org>,
Jeremy Fitzhardinge <jeremy@...source.com>,
Chris Wright <chrisw@...s-sol.org>,
Rusty Russell <rusty@...tcorp.com.au>,
virtualization@...ts.osdl.org
Subject: Re: [PATCH] I386: Deactivate the test for the dead CONFIG_DEBUG_PAGE_TYPE
variable.
Stefan Richter wrote:
> Robert P. J. Day wrote:
>
>> Signed-off-by: Robert P. J. Day <rpjday@...dspring.com>
>>
>> ---
>>
>> diff --git a/arch/i386/kernel/vmi.c b/arch/i386/kernel/vmi.c
>>
>
> Maintainers are apparently those under "PARAVIRT_OPS INTERFACE".
> CCs added.
>
>
>> index c12720d..e3ce5c8 100644
>> --- a/arch/i386/kernel/vmi.c
>> +++ b/arch/i386/kernel/vmi.c
>> @@ -235,7 +235,7 @@ static void vmi_nop(void)
>> {
>> }
>>
>> -#ifdef CONFIG_DEBUG_PAGE_TYPE
>> +#if 0 /* debug page type */
>>
>> #ifdef CONFIG_X86_PAE
>> #define MAX_BOOT_PTS (2048+4+1)
>> @@ -336,7 +336,7 @@ static void vmi_check_page_type(u32 pfn, int type)
>> #else
>> #define vmi_set_page_type(p,t) do { } while (0)
>> #define vmi_check_page_type(p,t) do { } while (0)
>> -#endif
>> +#endif /* debug page type */
>>
>> #ifdef CONFIG_HIGHPTE
>> static void *vmi_kmap_atomic_pte(struct page *page, enum km_type type)
>>
>
> This misnamed CONFIG_DEBUG_PAGE_TYPE (it's not a Kconfig variable) has
> about 120 lines debug code dangling on it. So, replacing it by #if 0
> will hopefully motivate a kind janitor to send a removal patch for that
> debug code eventually. I don't do so just now because that code went in
> between 2.6.20 and 2.6.21-rc1, i.e. not so long ago.
>
Nack. This code was very tricky to get right and found some very
obscure bugs. I want to keep it around even in broken form for as long
as possible.
Also, it is not misnamed. I didn't add the rest of the code upstream
because it steals bits from struct page.
Zach
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists