[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20070716150421.c21d38c5.akpm@linux-foundation.org>
Date: Mon, 16 Jul 2007 15:04:21 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Yoann Padioleau <padator@...adoo.fr>
Cc: linux-janitors@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] potential parse error, drivers/serial/dz.h
On Mon, 16 Jul 2007 17:02:13 +0200
Yoann Padioleau <padator@...adoo.fr> wrote:
>
> potential parse error in declaration under a #ifdef.
A certain parse error, I'd say. How come nobody is reporting it?
> Signed-off-by: Yoann Padioleau <padator@...adoo.fr>
>
>
> diff --git a/drivers/serial/dz.h b/drivers/serial/dz.h
> index 9674d4e..9141c37 100644
> --- a/drivers/serial/dz.h
> +++ b/drivers/serial/dz.h
> @@ -125,8 +125,8 @@ #define DZ_XMIT_SIZE 4096
> #define DZ_WAKEUP_CHARS DZ_XMIT_SIZE/4
>
> #ifdef MODULE
> -int init_module (void)
> -void cleanup_module (void)
> +int init_module (void);
> +void cleanup_module (void);
> #endif
>
> #endif /* DZ_SERIAL_H */
I don't think these symbols are actually implemented in anything which
uses this header. If they _do_ exist then they are awfully named and
should be renamed ASAP. Or they should be made static.
However I suspect they just don't exist, and this stuff should be simply
deleted.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists