[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <200707172236.28895.rjw@sisk.pl>
Date: Tue, 17 Jul 2007 22:36:27 +0200
From: "Rafael J. Wysocki" <rjw@...k.pl>
To: Andrew Morton <akpm@...ux-foundation.org>
Cc: LKML <linux-kernel@...r.kernel.org>,
Alan Stern <stern@...land.harvard.edu>,
David Brownell <david-b@...bell.net>,
Len Brown <len.brown@...el.com>,
Nigel Cunningham <nigel@...el.suspend2.net>,
Pavel Machek <pavel@....cz>, Shaohua Li <shaohua.li@...el.com>,
Johannes Berg <johannes@...solutions.net>,
Paul Mackerras <paulus@...ba.org>,
Russell King <rmk@....linux.org.uk>
Subject: [Resend][PATCH 0/9] PM: Update global suspend and hibernation operations framework
Hi,
This series of patches implements changes that are possible/necessary/desirable
(IMO) after the introduction of the .set_target() method in 'struct pm_ops' (commit
2391dae3e36c19fe668c71eac2eb8344dbaaf46d).
The patches in the series make the following changes:
* make ACPI use the new .set_target() method in 'struct pm_ops'
* add an ACPI helper function for the devices to determine the power state
to put the device into
* move the definition of 'struct pm_ops' to <include/suspend.h>
* change the name of 'struct pm_ops' to 'struct platform_suspend_ops' and
modify the names of some related functions and global variables accordingly
* modify 'struct platform_suspend_ops' so that .prepare() and .finish() don't
take arguments (.enter() still takes the state argument, because some
platforms don't need to implement the other callbacks)
* make some functions normally defined in kernel/power/main.c be also defined
when CONFIG_PM is unset
* make suspend_ops be a static variable
* rework 'struct hibernation_ops' to add the new method analogous to
.set_target()
* rename 'struct hibernation_ops' to 'struct platform_hibernation_ops' (in
analogy with 'struct platform_suspend_ops')
The series in on top of the current -git with the following patches, currently
in -mm or in the ACPI tree, applied:
swsusp-remove-incorrect-code-from-userc.patch
swsusp-remove-code-duplication-between-diskc-and-userc.patch
swsusp-introduce-restore-platform-operations.patch
swsusp-fix-hibernation-code-ordering.patch
hibernation-prepare-to-enter-the-low-power-state.patch
pm-introduce-hibernation-and-suspend-notifiers.patch
acpi-do-not-attempt-to-run-s1-standby-workarounds-while-hibernating.patch
pm-reduce-code-duplication-between-mainc-and-userc-updated.patch
Greetings,
Rafael
--
"Premature optimization is the root of all evil." - Donald Knuth
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists