[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20070719024730.03609f1f.akpm@linux-foundation.org>
Date: Thu, 19 Jul 2007 02:47:30 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Geert Uytterhoeven <Geert.Uytterhoeven@...ycom.com>
Cc: Paul Mackerras <paulus@...ba.org>, Jens Axboe <axboe@...nel.dk>,
"James E.J. Bottomley" <James.Bottomley@...elEye.com>,
Linux/PPC Development <linuxppc-dev@...abs.org>,
Linux Kernel Development <linux-kernel@...r.kernel.org>,
linux-scsi@...r.kernel.org,
Geoff Levand <geoffrey.levand@...sony.com>
Subject: Re: [patch 2/3] ps3: BD/DVD/CD-ROM Storage Driver
On Thu, 19 Jul 2007 11:39:32 +0200 (CEST) Geert Uytterhoeven <Geert.Uytterhoeven@...ycom.com> wrote:
> > Oh dear.
> >
> > ps3rom_priv(dev) = host;
> >
> > that's 'orrid. We have an identifier pretending to be a function, only we
> > go and treat it as an lvalue.
> >
> > I mean, C code should look like C code, and the above just doesn't.
> >
> > Sigh.
>
> Do you prefer
>
> static inline struct ps3rom_private *ps3rom_priv_get(struct ps3_storage_device
> *dev)
> {
> return dev->sbd.core.driver_data;
> }
>
> static inline void ps3rom_priv_set(struct ps3_storage_device *dev,
> struct ps3rom_private *priv)
> {
> dev->sbd.core.driver_data = priv;
> }
>
> instead?
Yes. Not that it's a terribly important issue, particularly down in the
dark and dusty corners where this code lurks. The "function" as an lvalue
thing would be more obnoxious in some top-level interface. We probably
already have some :(
If it were mine I'd open-code the "set" and do the "get" as a static
inline. Or you could leave it as-is and go off and do something more
important ;)
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists