[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <46A23C81.8040300@linux.vnet.ibm.com>
Date: Sat, 21 Jul 2007 22:34:01 +0530
From: Balbir Singh <balbir@...ux.vnet.ibm.com>
To: Paul Menage <menage@...gle.com>
CC: Andrew Morton <akpm@...ux-foundation.org>,
Peter Zijlstra <a.p.zijlstra@...llo.nl>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Linux Containers <containers@...ts.osdl.org>,
YAMAMOTO Takashi <yamamoto@...inux.co.jp>,
Linux MM Mailing List <linux-mm@...ck.org>,
Vaidyanathan Srinivasan <svaidy@...ux.vnet.ibm.com>,
Pavel Emelianov <xemul@...nvz.org>,
Dave Hansen <haveblue@...ibm.com>,
Eric W Biederman <ebiederm@...ssion.com>
Subject: Re: [RFC][-mm PATCH 2/8] Memory controller containers setup (v3)
Paul Menage wrote:
> On 7/20/07, Balbir Singh <balbir@...ux.vnet.ibm.com> wrote:
>>
>> +config CONTAINER_MEM_CONT
>> + bool "Memory controller for containers"
>> + select CONTAINERS
>
> Andrew asked me to not use "select" in Kconfig files due to some
> unspecified problems seen in the past, so my latest patchset makes the
> subsystems depend on containers rather than selecting them; I prefer
> the select approach over the dependency approach, but if select does
> have problems then we should be consistent.
>
I'll change it to depends
>> +static struct cftype mem_container_usage = {
>> + .name = "mem_usage",
>> + .private = RES_USAGE,
>
> For V11, the .name field should just be called something like 'usage';
> the subsystem name is automatically prefixed.
>
Will change
>> +
>> +static int mem_container_create(struct container_subsys *ss,
>> + struct container *cont)
>> +{
>> + struct mem_container *mem;
>> +
>> + mem = kzalloc(sizeof(struct mem_container), GFP_KERNEL);
>> + if (!mem)
>> + return -ENOMEM;
>> +
>> + res_counter_init(&mem->res);
>> + cont->subsys[mem_container_subsys_id] = &mem->css;
>> + mem->css.container = cont;
>> + return 0;
>
> For the V11 patchset, you'll want to replace these three lines with just
>
> return &mem->css;
>
Will do
>> +static int mem_container_populate(struct container_subsys *ss,
>> + struct container *cont)
>> +{
>> + int rc = 0;
>> +
>> + rc = container_add_file(cont, &mem_container_usage);
>> + if (rc < 0)
>> + goto err;
>> +
>> + rc = container_add_file(cont, &mem_container_limit);
>> + if (rc < 0)
>> + goto err;
>> +
>> + rc = container_add_file(cont, &mem_container_failcnt);
>> + if (rc < 0)
>> + goto err;
>
> There's a container_add_files() API in V10 and above that lets you
> register an array of files in one go.
>
Cool! I'll migrate to that.
>> +
>> +err:
>> + return rc;
>> +}
>> +
>> +struct container_subsys mem_container_subsys = {
>> + .name = "mem_container",
>
> Maybe just "memory" or "pages" for the container name?
>
Traditionally names like memory_control have been used to
indicate the purpose of the controller. I understand that
container is an overloaded term, so I guess memory might
a be better name.
> Paul
--
Warm Regards,
Balbir Singh
Linux Technology Center
IBM, ISTL
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists