lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Fri, 27 Jul 2007 15:17:59 +0200
From:	Uli Luckas <u.luckas@...d.de>
To:	LKML <linux-kernel@...r.kernel.org>, bryan.wu@...log.com
Cc:	Yoann Padioleau <padator@...adoo.fr>,
	kernel-janitors@...r.kernel.org, aubrey.li@...log.com,
	akpm@...ux-foundation.org
Subject: Re: [PATCH 04/68] 0 -> NULL, for arch/blackfin

On Friday, 27. July 2007, Bryan Wu wrote:
> On Fri, 2007-07-27 at 11:44 +0200, Yoann Padioleau wrote:
> > When comparing a pointer, it's clearer to compare it to NULL than to 0.
> >
> > Here is an excerpt of the semantic patch:
> >
> > @@
> > expression *E;
> > @@
> >
> >   E ==
> > - 0
> > + NULL
> >
> > @@
> > expression *E;
> > @@
> >
> >   E !=
> > - 0
> > + NULL
> >
> > Signed-off-by: Yoann Padioleau <padator@...adoo.fr>
> > Cc: aubrey.li@...log.com
> > Cc: bryan.wu@...log.com
> > Cc: akpm@...ux-foundation.org
> > ---
> >
> >  traps.c |    2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/arch/blackfin/kernel/traps.c b/arch/blackfin/kernel/traps.c
> > index 3909f5b..691c66d 100644
> > --- a/arch/blackfin/kernel/traps.c
> > +++ b/arch/blackfin/kernel/traps.c
> > @@ -546,7 +546,7 @@ void dump_bfin_regs(struct pt_regs *fp,
> >  	}
> >
> >  	printk(KERN_EMERG "return address: [0x%p]; contents of:", retaddr);
> > -	if (retaddr != 0 && retaddr <= (void *)physical_mem_end
> > +	if (retaddr != NULL && retaddr <= (void *)physical_mem_end
> >  #if L1_CODE_LENGTH != 0
> >  	    /* FIXME: Copy the code out of L1 Instruction SRAM through dma
> >  	       memcpy.  */
>
> Why not just use " if (!E)" instead of " if (E != NULL)"?
> more readable?
>
Or even "if (E)"

Uli

-- 

------- ROAD ...the handyPC Company - - -  ) ) )

Uli Luckas
Software Development

ROAD GmbH
Bennigsenstr. 14 | 12159 Berlin | Germany
fon: +49 (30) 230069 - 64 | fax: +49 (30) 230069 - 69
url: www.road.de

Amtsgericht Charlottenburg: HRB 96688 B
Managing directors: Hans-Peter Constien, Hubertus von Streit
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ