[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.LFD.0.999.0707312334260.28746@enigma.security.iitk.ac.in>
Date: Tue, 31 Jul 2007 23:36:10 +0530 (IST)
From: Satyam Sharma <satyam@...radead.org>
To: Greg KH <gregkh@...e.de>
cc: Andreas Schwab <schwab@...e.de>,
WANG Cong <xiyou.wangcong@...il.com>,
Christian Borntraeger <borntraeger@...ibm.com>,
jack@...keye.stone.uk.eu.org, linux-kernel@...r.kernel.org,
trivial@...nel.org
Subject: Re: [Patch 09/16] Remove unnecessary kmalloc casts in the pci
subsystem.
On Tue, 31 Jul 2007, Greg KH wrote:
> On Tue, Jul 31, 2007 at 06:20:29PM +0200, Andreas Schwab wrote:
> > Greg KH <gregkh@...e.de> writes:
> >
> > > On Tue, Jul 31, 2007 at 10:46:19PM +0800, WANG Cong wrote:
> > >> However, I think using resource_size_t is a bit better than unsigned long,
> > >> so that we don't need to check the defination of it.
> > >>
> > >> - res->start = (unsigned long)kmalloc(*size, GFP_KERNEL);
> > >> + res->start = (resource_size_t)kmalloc(*size, GFP_KERNEL);
> > >>
> > >> Is this change OK?
> > >
> > > Yes, that is the proper cast to have here.
> >
> > It will generate a warning when resoure_size_t is 64bit on a 32bit arch.
>
> How?
warning: cast from pointer to integer of different size
(it's from smaller to larger size, so not really truncation,
but gcc does barf)
> And if so, what should the proper cast be?
sizeof(unsigned long) == sizeof(void *) should always be true.
Satyam
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists