[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1186530902.22283.77.camel@localhost>
Date: Tue, 07 Aug 2007 16:55:02 -0700
From: Dave Hansen <haveblue@...ibm.com>
To: Matt Mackall <mpm@...enic.com>
Cc: linux-kernel@...r.kernel.org, serue@...ibm.com
Subject: Re: [RFC][PATCH 3/5] pagemap: remove open-coded sizeof(unsigned
long)
On Tue, 2007-08-07 at 18:40 -0500, Matt Mackall wrote:
> On Tue, Aug 07, 2007 at 03:33:02PM -0700, Dave Hansen wrote:
> > +#define PAGEMAP_ENTRY_SIZE_BYTES sizeof(unsigned long)
> > +
> > static int add_to_pagemap(unsigned long addr, unsigned long pfn,
> > struct pagemapread *pm)
> > {
> > __put_user(pfn, pm->out);
> > pm->out++;
> > - pm->pos += sizeof(unsigned long);
> > - pm->count -= sizeof(unsigned long);
> > - pm->next = addr + PAGE_SIZE;
> > + pm->pos += PAGEMAP_ENTRY_SIZE_BYTES;
> > + pm->count -= PAGEMAP_ENTRY_SIZE_BYTES;
>
> I think deleting ->next is a little premature here?
It is. I'll fix that up.
-- Dave
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists