[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <20070913183744.7e074852.akpm@linux-foundation.org>
Date: Thu, 13 Sep 2007 18:37:44 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Zhang Rui <rui.zhang@...el.com>
Cc: Oliver Neukum <oliver@...kum.org>, linux-fsdevel@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-acpi@...r.kernel.org
Subject: Re: [PATCH] [-mm] FS: file name must be unique in the same dir in
procfs
>
> From: Zhang Rui <rui.zhang@...el.com>
> File name should be unique in the same directory.
>
> In order to keep the back-compatibility, only a warning is given
> currently, but actions must be taken to fix it when such duplicates
> are detected.
>
> Bug report and a simple fix can be found here:
> http://bugzilla.kernel.org/show_bug.cgi?id=8798
>
> Signed-off-by: Zhang Rui <rui.zhang@...el.com>
> ---
> fs/proc/generic.c | 12 ++++++++++++
> 1 file changed, 12 insertions(+)
>
> Index: linux-2.6/fs/proc/generic.c
> ===================================================================
> --- linux-2.6.orig/fs/proc/generic.c
> +++ linux-2.6/fs/proc/generic.c
> @@ -523,6 +523,7 @@ static const struct inode_operations pro
>
> static int proc_register(struct proc_dir_entry * dir, struct
> proc_dir_entry * dp)
Your email client is wordwrapping the text.
> {
> + struct proc_dir_entry *tmp = NULL;
That initialisation is unneeded - I removed it.
`tmp' is always a crappy name for anything. I renamed it to `de'.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists