[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.LFD.0.999.0709201746090.17093@enigma.security.iitk.ac.in>
Date: Thu, 20 Sep 2007 17:51:42 +0530 (IST)
From: Satyam Sharma <satyam@...radead.org>
To: Ken'ichi Ohmichi <oomichi@....nes.nec.co.jp>
cc: Andrew Morton <akpm@...ux-foundation.org>,
Adrian Bunk <bunk@...nel.org>,
kexec-ml <kexec@...ts.infradead.org>,
lkml <linux-kernel@...r.kernel.org>,
David Rientjes <rientjes@...gle.com>,
Joe Perches <joe@...ches.com>
Subject: Re: [PATCH 5/4] [-mm patch] Rename macros returning the size.
Hi,
On Thu, 20 Sep 2007, Ken'ichi Ohmichi wrote:
>
> [PATCH 5/4] [-mm patch] Rename macros returning the size.
> The #define SIZE() should be renamed STRUCT_SIZE() since it's always
> returning the size of the struct with a given name. This would allow
> TYPEDEF_SIZE() to simply become SIZE() since it need not be used
> exclusively for typedefs. This idea is David Rientjes's.
> http://www.ussg.iu.edu/hypermail/linux/kernel/0709.1/1964.html
>
> Thanks
> Ken'ichi Ohmichi
>
> ---
> Signed-off-by: David Rientjes <rientjes@...gle.com>
Hmm, I think adding a s-o-b line for David here isn't quite correct.
When someone reviews a patch and gives a suggestion, you only need to
copy him on the next iteration (and he may ack it or whatever, if he
wants) -- but adding a s-o-b line like that ends up (incorrectly)
denoting that he came between the author-to-git-commit chain ...
> Signed-off-by: Ken'ichi Ohmichi <oomichi@....nes.nec.co.jp>
> --- a/include/linux/kexec.h 2007-09-18 15:22:19.000000000 +0900
> +++ b/include/linux/kexec.h 2007-09-18 15:23:22.000000000 +0900
> @@ -131,10 +131,10 @@ unsigned long paddr_vmcoreinfo_note(void
> vmcoreinfo_append_str("SYMBOL(%s)=%lx\n", #name, (unsigned long)&name)
> #define VMCOREINFO_SIZE(name) \
> vmcoreinfo_append_str("SIZE(%s)=%lu\n", #name, \
> - (unsigned long)sizeof(struct name))
> -#define VMCOREINFO_TYPEDEF_SIZE(name) \
> - vmcoreinfo_append_str("SIZE(%s)=%lu\n", #name, \
> (unsigned long)sizeof(name))
> +#define VMCOREINFO_STRUCT_SIZE(name) \
> + vmcoreinfo_append_str("SIZE(%s)=%lu\n", #name, \
> + (unsigned long)sizeof(struct name))
> #define VMCOREINFO_OFFSET(name, field) \
> vmcoreinfo_append_str("OFFSET(%s.%s)=%lu\n", #name, #field, \
> (unsigned long)&(((struct name *)0)->field))
Please use %zu and lose all the ugly (unsigned long) casts here.
Otherwise it looks good,
Satyam
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists