lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sat, 22 Sep 2007 15:03:06 +0200
From:	Michael Kerrisk <>
To:	David Härdeman <>
CC:	Thomas Gleixner <>,,,,,,,,,,,
Subject: Re: RFC: A revised timerfd API

David Härdeman wrote:
> On Tue, September 18, 2007 13:30, Thomas Gleixner wrote:
>>>>         timer_gettime(fd | POSIX_TIMER_FD, .....);
>> If we use the most significant bit for POSIX_TIMER_FD, we should be
>> fine.
> I think alternative b) - three new syscalls, sounds better.
> The only negatives so far are that it adds more syscalls and that it might
> require code duplication with posix timers. The syscall numbers argument
> seemed not to be very important and the code duplication should be fixable
> by refactoring the code so that more is shared between the two systems (I
> assume).

Yes, I'm inclined to agree with you on both points.

> Overloading file descriptors with flags looks ugly, is there any other
> syscall which does that?

AFAIK there is no other syscall that does that.  I agree that it's not very



Michael Kerrisk
maintainer of Linux man pages Sections 2, 3, 4, 5, and 7

Want to help with man page maintenance?  Grab the latest tarball at
read the HOWTOHELP file and grep the source files for 'FIXME'.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists