[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <46FD8FE1.4090507@goop.org>
Date: Fri, 28 Sep 2007 16:36:01 -0700
From: Jeremy Fitzhardinge <jeremy@...p.org>
To: "Nakajima, Jun" <jun.nakajima@...el.com>
CC: Andi Kleen <ak@...e.de>, Zachary Amsden <zach@...are.com>,
Rusty Russell <rusty@...tcorp.com.au>,
Avi Kivity <avi@...ranet.com>,
Glauber de Oliveira Costa <glommer@...il.com>,
Anthony Liguori <anthony@...emonkey.ws>,
Virtualization Mailing List <virtualization@...ts.osdl.org>,
Ingo Molnar <mingo@...e.hu>,
Thomas Gleixner <tglx@...utronix.de>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Alan Cox <alan@...rguk.ukuu.org.uk>
Subject: Re: [PATCH RFC] paravirt_ops: refactor struct paravirt_ops into smaller
pv_*_ops
Nakajima, Jun wrote:
> Jeremy Fitzhardinge wrote:
>
>> This patch refactors the paravirt_ops structure into groups of
>> functionally related ops:
>>
>> pv_info - random info, rather than function entrypoints
>> pv_init_ops - functions used at boot time (some for module_init too)
>> pv_misc_ops - lazy mode, which didn't fit well anywhere else
>> pv_time_ops - time-related functions
>> pv_cpu_ops - various privileged instruction ops
>> pv_irq_ops - operations for managing interrupt state
>> pv_apic_ops - APIC operations
>> pv_mmu_ops - operations for managing pagetables
>>
>>
>
> Good. These make sense to me.
>
>
>> + .pv_irq_ops = {
>> + .init_IRQ = native_init_IRQ,
>> + .save_fl = native_save_fl,
>> + .restore_fl = native_restore_fl,
>> + .irq_disable = native_irq_disable,
>> + .irq_enable = native_irq_enable,
>> + .safe_halt = native_safe_halt,
>> + .halt = native_halt,
>> + },
>>
>
> I think the halt stuff should be moved to pv_cpu_ops?
>
You mean halt's alternate "shutdown vcpu" meaning if you call it with
interrupts disabled? Yeah, I'd be happy to have an explicit op for
that, rather than making it a secondary overloaded meaning. And use
"safe_halt" for all uses of "wait for next interrupt".
>> + .pv_misc_ops = {
>> + .set_lazy_mode = paravirt_nop,
>> + },
>>
>
> Or you can split it to pv_cpu_ops and pv_mmu_ops, assuming that they
> don't need to interact with each other in terms of the lazy handling.
>
You mean have separate lazy_mmu and lazy_cpu (lazy_context_switch) ops?
Possible, but they're still exclusive. (I think VMI, at least, assumes
that you can't have lazy_mmu and lazy_cpu active at the same time, and
its nice to enforce this in the interface.)
But having a whole misc structure for this interface is pretty warty, I
admit.
J
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists