[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <470C5294.8060502@linuxtv.org>
Date: Wed, 10 Oct 2007 00:18:28 -0400
From: Michael Krufky <mkrufky@...uxtv.org>
To: Mauro Carvalho Chehab <mchehab@...radead.org>
CC: Jiri Slaby <jirislaby@...il.com>, video4linux-list@...hat.com,
daniel@...u.de, linux-kernel@...r.kernel.org, holger@...u.de,
v4l-dvb maintainer list <v4l-dvb-maintainer@...uxtv.org>,
Andrew Morton <akpm@...ux-foundation.org>
Subject: Re: [v4l-dvb-maintainer] [PATCH 3/3] V4L: cinergyT2, remove bad usage
of ERESTARTSYS
Mauro Carvalho Chehab wrote:
> Hi Jiri,
>
> Em Seg, 2007-10-08 às 13:41 +0100, Jiri Slaby escreveu:
>
>> cinergyT2, remove bad usage of ERESTARTSYS
>>
>> test of cinergyt2->disconnect_pending doesn't ensure pending signal and so
>> ERESTARTSYS would reach userspace, which is not permitted. Change it to
>> EAGAIN
>>
>>
>
> checkpatch.pl is complaining about your changeset:
>
> do not use assignment in if condition
> #82: FILE: drivers/media/dvb/cinergyT2/cinergyT2.c:492:
> + if ((err = mutex_lock_interruptible(&cinergyt2->wq_sem)))
>
> do not use assignment in if condition
> #86: FILE: drivers/media/dvb/cinergyT2/cinergyT2.c:495:
> + if ((err = mutex_lock_interruptible(&cinergyt2->sem)))
>
> do not use assignment in if condition
> #133: FILE: drivers/media/dvb/cinergyT2/cinergyT2.c:1036:
> + if ((err = mutex_lock_interruptible(&cinergyt2->wq_sem)))
>
> do not use assignment in if condition
> #137: FILE: drivers/media/dvb/cinergyT2/cinergyT2.c:1039:
> + if ((err = mutex_lock_interruptible(&cinergyt2->sem)))
Is this illegal as per kernel codingstyle? I could understand if we may
want to avoid this sort of thing for the sake of code readability, but
this seems 100% proper to me, especially considering that we're simply
trying to catch an error return code.
One of the things that I really enjoy about the c programming language
is the fact that you can string many operations together into a single
statement through the use of logic. I hate the thought of a patch being
nacked because of the above. :-/
If this is indeed kernel codingstyle, then IMHO, we should let it slide
for catching error return codes.
Regards,
Mike Krufky
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists