[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20071011212921.f97c8423.randy.dunlap@oracle.com>
Date: Thu, 11 Oct 2007 21:29:21 -0700
From: Randy Dunlap <randy.dunlap@...cle.com>
To: Michael Krufky <mkrufky@...uxtv.org>
Cc: Mauro Carvalho Chehab <mchehab@...radead.org>,
Jiri Slaby <jirislaby@...il.com>, video4linux-list@...hat.com,
daniel@...u.de, linux-kernel@...r.kernel.org, holger@...u.de,
v4l-dvb maintainer list <v4l-dvb-maintainer@...uxtv.org>,
Andrew Morton <akpm@...ux-foundation.org>
Subject: Re: [v4l-dvb-maintainer] [PATCH 3/3] V4L: cinergyT2, remove bad
usage of ERESTARTSYS
On Wed, 10 Oct 2007 00:18:28 -0400 Michael Krufky wrote:
> Mauro Carvalho Chehab wrote:
> > Hi Jiri,
> >
> > Em Seg, 2007-10-08 às 13:41 +0100, Jiri Slaby escreveu:
> >
> >> cinergyT2, remove bad usage of ERESTARTSYS
> >>
> >> test of cinergyt2->disconnect_pending doesn't ensure pending signal and so
> >> ERESTARTSYS would reach userspace, which is not permitted. Change it to
> >> EAGAIN
> >>
> >>
> >
> > checkpatch.pl is complaining about your changeset:
> >
> > do not use assignment in if condition
> > #82: FILE: drivers/media/dvb/cinergyT2/cinergyT2.c:492:
> > + if ((err = mutex_lock_interruptible(&cinergyt2->wq_sem)))
> >
> > do not use assignment in if condition
> > #86: FILE: drivers/media/dvb/cinergyT2/cinergyT2.c:495:
> > + if ((err = mutex_lock_interruptible(&cinergyt2->sem)))
> >
> > do not use assignment in if condition
> > #133: FILE: drivers/media/dvb/cinergyT2/cinergyT2.c:1036:
> > + if ((err = mutex_lock_interruptible(&cinergyt2->wq_sem)))
> >
> > do not use assignment in if condition
> > #137: FILE: drivers/media/dvb/cinergyT2/cinergyT2.c:1039:
> > + if ((err = mutex_lock_interruptible(&cinergyt2->sem)))
>
> Is this illegal as per kernel codingstyle? I could understand if we may
> want to avoid this sort of thing for the sake of code readability, but
> this seems 100% proper to me, especially considering that we're simply
> trying to catch an error return code.
Anyway, it's not strictly from CodingStyle. The closest that
CodingStyle has to say about it IMO is this:
"Don't put multiple assignments on a single line either. Kernel coding style
is super simple. Avoid tricky expressions."
Also, Andrew Morton and Christoph Hellwig push for splitting up
the if-assignment lines, so it's a trend over the past few
(probably) years. It's not real new.
> One of the things that I really enjoy about the c programming language
> is the fact that you can string many operations together into a single
> statement through the use of logic. I hate the thought of a patch being
> nacked because of the above. :-/
so you like the challenge of reading obfuscated code?
At any rate, it's rare that a patch is nacked only due to coding style,
unless it's blatant and occurs many times (like throughout the entire
source file).
> If this is indeed kernel codingstyle, then IMHO, we should let it slide
> for catching error return codes.
Nope.
---
~Randy
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists