[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20071017161308.GD6773@localdomain>
Date: Wed, 17 Oct 2007 11:13:08 -0500
From: Nathan Lynch <ntl@...ox.com>
To: Gautham R Shenoy <ego@...ibm.com>
Cc: Linus Torvalds <torvalds@...ux-foundation.org>,
Andrew Morton <akpm@...ux-foundation.org>,
linux-kernel@...r.kernel.org,
Srivatsa Vaddagiri <vatsa@...ibm.com>,
Rusty Russel <rusty@...tcorp.com.au>,
Dipankar Sarma <dipankar@...ibm.com>,
Oleg Nesterov <oleg@...sign.ru>, Ingo Molnar <mingo@...e.hu>,
Paul E McKenney <paulmck@...ibm.com>
Subject: Re: [RFC PATCH 2/4] Rename lock_cpu_hotplug to get_online_cpus
Hi Gautham-
Gautham R Shenoy wrote:
> Replace all lock_cpu_hotplug/unlock_cpu_hotplug from the kernel and use
> get_online_cpus and put_online_cpus instead as it highlights
> the refcount semantics in these operations.
Something other than "get_online_cpus", please? lock_cpu_hotplug()
protects cpu_present_map as well as cpu_online_map. For example, some
of the powerpc code modified in this patch is made a bit less clear
because it is manipulating cpu_present_map, not cpu_online_map.
> Index: linux-2.6.23/arch/powerpc/platforms/pseries/hotplug-cpu.c
> ===================================================================
> --- linux-2.6.23.orig/arch/powerpc/platforms/pseries/hotplug-cpu.c
> +++ linux-2.6.23/arch/powerpc/platforms/pseries/hotplug-cpu.c
> @@ -151,7 +151,7 @@ static int pseries_add_processor(struct
> for (i = 0; i < nthreads; i++)
> cpu_set(i, tmp);
>
> - lock_cpu_hotplug();
> + get_online_cpus();
>
> BUG_ON(!cpus_subset(cpu_present_map, cpu_possible_map));
>
> @@ -188,7 +188,7 @@ static int pseries_add_processor(struct
> }
> err = 0;
> out_unlock:
> - unlock_cpu_hotplug();
> + put_online_cpus();
> return err;
> }
>
> @@ -209,7 +209,7 @@ static void pseries_remove_processor(str
>
> nthreads = len / sizeof(u32);
>
> - lock_cpu_hotplug();
> + get_online_cpus();
> for (i = 0; i < nthreads; i++) {
> for_each_present_cpu(cpu) {
> if (get_hard_smp_processor_id(cpu) != intserv[i])
> @@ -223,7 +223,7 @@ static void pseries_remove_processor(str
> printk(KERN_WARNING "Could not find cpu to remove "
> "with physical id 0x%x\n", intserv[i]);
> }
> - unlock_cpu_hotplug();
> + put_online_cpus();
> }
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists