[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20071018082221.GE6773@localdomain>
Date: Thu, 18 Oct 2007 03:22:21 -0500
From: Nathan Lynch <ntl@...ox.com>
To: Gautham R Shenoy <ego@...ibm.com>
Cc: Linus Torvalds <torvalds@...ux-foundation.org>,
Andrew Morton <akpm@...ux-foundation.org>,
linux-kernel@...r.kernel.org,
Srivatsa Vaddagiri <vatsa@...ibm.com>,
Rusty Russel <rusty@...tcorp.com.au>,
Dipankar Sarma <dipankar@...ibm.com>,
Oleg Nesterov <oleg@...sign.ru>, Ingo Molnar <mingo@...e.hu>,
Paul E McKenney <paulmck@...ibm.com>
Subject: Re: [RFC PATCH 2/4] Rename lock_cpu_hotplug to get_online_cpus
Gautham R Shenoy wrote:
> Hi Nathan,
> > Hi Gautham-
> >
> > Gautham R Shenoy wrote:
> > > Replace all lock_cpu_hotplug/unlock_cpu_hotplug from the kernel and use
> > > get_online_cpus and put_online_cpus instead as it highlights
> > > the refcount semantics in these operations.
> >
> > Something other than "get_online_cpus", please? lock_cpu_hotplug()
> > protects cpu_present_map as well as cpu_online_map. For example, some
> > of the powerpc code modified in this patch is made a bit less clear
> > because it is manipulating cpu_present_map, not cpu_online_map.
>
> A quick look at the code, and I am wondering why is lock_cpu_hotplug()
> used there in the first place. It doesn't look like we require any
> protection against cpus coming up/ going down in the code below,
> since the cpu-hotplug operation doesn't affect the cpu_present_map.
The locking is necessary. Changes to cpu_online_map and
cpu_present_map must be serialized; otherwise you could end up trying
to online a cpu as it is being removed (i.e. cleared from
cpu_present_map). Online operations must check that a cpu is present
before bringing it up (kernel/cpu.c):
/* Requires cpu_add_remove_lock to be held */
static int __cpuinit _cpu_up(unsigned int cpu, int tasks_frozen)
{
int ret, nr_calls = 0;
void *hcpu = (void *)(long)cpu;
unsigned long mod = tasks_frozen ? CPU_TASKS_FROZEN : 0;
if (cpu_online(cpu) || !cpu_present(cpu))
return -EINVAL;
....
> Can't we use another mutex here instead of the cpu_hotplug mutex here ?
I guess so, but I don't really see the need...
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists