lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sun, 04 Nov 2007 08:11:10 -0800
From:	Roland Dreier <rdreier@...co.com>
To:	Romano Giannetti <romanol@...omillas.es>
Cc:	Pierre Ossman <drzeus-mmc@...eus.cx>, linux-kernel@...r.kernel.org
Subject: Re: 2.6.34-rc1 eat my photo SD card :-(

I had something similar recently, trying to access an SD card in the
internal drive of my thinkpad X60.  Fortunately, the data wasn't
actually corrupted, but when I tried to copy the picture files off the
card, I saw garbage filenames in the picture directory, and I saw this
in the kernel log:

    [84797.855013] mmc0: new SD card at address b368
    [84798.227299] mmcblk0: mmc0:b368 SD    501248KiB 
    [84798.227541]  mmcblk0: p1
    [84810.378736] FAT: Filesystem panic (dev mmcblk0p1)
    [84810.378748]     invalid access to FAT (entry 0x0000bfff)
    [84810.378753]     File system has been set read-only
    [84810.378812] FAT: Filesystem panic (dev mmcblk0p1)
    [84810.378816]     invalid access to FAT (entry 0x0000ffbf)

(and on quite a bit longer)

When I put the same card back in the camera and used the camera's dock
to access the data via USB mass storage, everything worked fine.  So
it does seem to be at least somewhat MMC-related.

Please let me know if there's further debug info that might be
helpful... this problem seems to be completely reproducible on my
system.  I'm running a post 2.6.24-rc1 git tree
(v2.6.24-rc1-521-g54866f0 according to git describe).

 - R.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists