[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <474EFDF8.8090506@zytor.com>
Date: Thu, 29 Nov 2007 09:59:20 -0800
From: "H. Peter Anvin" <hpa@...or.com>
To: Christoph Hellwig <hch@...radead.org>
CC: Roland McGrath <roland@...hat.com>,
Andrew Morton <akpm@...ux-foundation.org>,
Linus Torvalds <torvalds@...ux-foundation.org>,
linux-kernel@...r.kernel.org, Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...e.hu>
Subject: Re: [PATCH x86/mm 08/11] x86 ia32 ptrace getreg/putreg merge
Christoph Hellwig wrote:
> On Thu, Nov 29, 2007 at 04:00:31AM -0800, Roland McGrath wrote:
>> +#define R32(l,q) \
>> + case offsetof(struct user32, regs.l): \
>> + regs->q = value; break
>> +
>> +#define SEG32(rs) \
>> + case offsetof(struct user32, regs.rs): \
>> + return set_segment_reg(child, \
>> + offsetof(struct user_regs_struct, rs), \
>> + value); \
>> + break
>
> The code would be a lot more readable if you just opencoded this in the
> caller instead of these obsfucated macros.
>
For better or worse, though, that is style of existing code. I
personally found it easy to deal with when I went through the code recently.
-hpa
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists