[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20071204192738.54e79a97.akpm@linux-foundation.org>
Date: Tue, 4 Dec 2007 19:27:38 -0800
From: Andrew Morton <akpm@...ux-foundation.org>
To: tsbogend@...ha.franken.de (Thomas Bogendoerfer)
Cc: linux-kernel@...r.kernel.org, linux-mips@...ux-mips.org,
Andy Whitcroft <apw@...dowen.org>,
Alan Cox <alan@...rguk.ukuu.org.uk>
Subject: Re: [PATCH] SC26XX: New serial driver for SC2681 uarts
On Wed, 5 Dec 2007 00:41:12 +0100 tsbogend@...ha.franken.de (Thomas Bogendoerfer) wrote:
> On Mon, Dec 03, 2007 at 03:53:17PM -0800, Andrew Morton wrote:
> > On Sun, 2 Dec 2007 20:43:46 +0100 (CET)
> > Thomas Bogendoerfer <tsbogend@...ha.franken.de> wrote:
> >
> > > New serial driver for SC2681/SC2691 uarts. Older SNI RM400 machines are
> > > using these chips for onboard serial ports.
> > >
> >
> > Little things...
>
> here is an updated version.
>
> Changes:
> - use container_of
> - remove not needed locking
> - remove inlines
> - fix macros with double argument reference
>
> Thomas.
> --
>
> New serial driver for SC2681/SC2691 uarts. Older SNI RM400 machines are
> using these chips for onboard serial ports.
>
grumble.
These:
> +#define READ_SC(p, r) readb((p)->membase + RD_##r)
> +#define WRITE_SC(p, r, v) writeb((v), (p)->membase + WR_##r)
and these:
> +#define READ_SC_PORT(p, r) read_sc_port(p, RD_PORT_##r)
> +#define WRITE_SC_PORT(p, r, v) write_sc_port(p, WR_PORT_##r, v)
really don't need to exist. All they do is make the code harder to read.
Think of the poor reader who sees this:
status = READ_SC_PORT(port, SR);
and then goes madly searching for "SR". After a while, our confused reader
might think to go look at the definition of READ_SC_PORT, after which our
reader will emulate a C preprocessor in wetware and will eventually construct
then hunt down RD_PORT_SR and will then hopefully remember what the heck he was
trying to do in the first place.
This sucks.
Code is written once and is read a thousand times. Please optimise for
reading.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists