lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Fri, 07 Dec 2007 13:23:16 -0500
From:	Bill Davidsen <>
To:	Justin Piszcz <>
Subject: Re: x86_64: floppy not working: p35 chipset

Justin Piszcz wrote:
> On Fri, 7 Dec 2007, Bill Davidsen wrote:
>> Justin Piszcz wrote:
>>> Trying to format a floppy (2-3 of them) on a GA-P35-DS4 2.0 with a 
>>> regular Sony floppy on Debian x86_64 with kernel
>>> # fdformat /dev/fd0
>>> Could not determine current format type: No such device
>>> # mformat a:
>>> mformat: Could not get geometry of device (No such device)
>>> #
>>> # cat /proc/interrupts |grep floppy
>>>   6:         38         37         39         41   IO-APIC-edge      
>>> floppy
>>> # dmesg|grep -A1 fd0
>>> [   52.689487] Floppy drive(s): fd0 is 1.44M
>>> [   52.704661] FDC 0 is a post-1991 82077
>>> During the 'attempted format'
>>> I've tried a few different floppies, the result is the same.  The 
>>> system is 64-bit only, no 32-bit emulation is enabled using a strict 
>>> 64-bit-only userland.  Has anyone else gotten their floppy drive to 
>>> work under 64-bit?
>>> Is this just a case of a DOA floppy drive or is something else wrong?
>> Maybe booting from a 32 bit live CD would help determine that. It 
>> certainly was seen at boot time. Didn't get hooked to some SCSI 
>> device name by udev, did it?
>> -- 
>> Bill Davidsen <>
>>  "We have more to fear from the bungling of the incompetent than from
>> the machinations of the wicked."  - from Slashdot
> Retried with some other floppies and later tried the original, 
> everything seems to be working now, must have been a bad floppy/some 
> transient issue.

Great! I did test that FC8 with a Fedora kernel will see and use the 
floppy. Even found a floppy to use. Now I have to figure out why I have 
a floppy with a gzipped ext2 filesystem on it. :-(
Doesn't appear to be bootable, I thought it might be SYSLINUX for an old 
system which couldn't boot from CD or USB, but that doesn't seem to be 
the case.

Anyway, glad the problem went away.

Bill Davidsen <>
  "Woe unto the statesman who makes war without a reason that will still
  be valid when the war is over..." Otto von Bismark 

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists