lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 7 Dec 2007 15:06:55 -0500
From:	"J. Bruce Fields" <>
To:	Erez Zadok <>
	"Eric W. Biederman" <>,
	"Rafael J. Wysocki" <>, Pavel Machek <>,
	Pavel Emelyanov <>,
	"David S. Miller" <>,
	Ingo Molnar <>,
	Andrew Morton <>,
	Herbert Xu <>
Subject: Re: [NFS] NFSv2/3 broken exporting/mounting (permission denied) in

On Fri, Dec 07, 2007 at 03:00:13PM -0500, Erez Zadok wrote:
> In message <>, "J. Bruce Fields" writes:
> > On Thu, Dec 06, 2007 at 09:20:41PM -0500, Erez Zadok wrote:
> > > I get a "permission denied" when trying to mount a localhost nfsv2/3
> > > exported volume, on v2.6.24-rc4-124-gf194d13.  It works w/ nfsv4 mounting.
> > > It worked fine in 2.6.24-rc3.  Here's a sequence of ops I tried:
> > > 
> > > # mount -t ext2 /dev/hdb1 /n/lower/b0
> > > # exportfs -o no_root_squash,rw localhost:/n/lower/b0
> > > # mount -t nfs -o nfsvers=3 localhost:/n/lower/b0 /mnt
> > 
> > What do you see if you watch the network traffic in ethereal?
> > 
> > --b.
> Bruce, I'm using nfs-utils-1.0.10-14.fc6 on an FC6 system with all latest
> FC6 patches.  Using git-bisect I was able to find the patch which broke it:

Wow, thanks for your work finding that.

> commit 2b1e300a9dfc3196ccddf6f1d74b91b7af55e416
> Author: Eric W. Biederman <>
> Date:   Sun Dec 2 00:33:17 2007 +1100
>     [NETNS]: Fix /proc/net breakage
>     Well I clearly goofed when I added the initial network namespace support
>     for /proc/net.  Currently things work but there are odd details visible to
>     user space, even when we have a single network namespace.
>     Since we do not cache proc_dir_entry dentries at the moment we can just
>     modify ->lookup to return a different directory inode depending on the
>     network namespace of the process looking at /proc/net, replacing the
>     current technique of using a magic and fragile follow_link method.
>     To accomplish that this patch:
>     - introduces a shadow_proc method to allow different dentries to
>       be returned from proc_lookup.
>     - Removes the old /proc/net follow_link magic
>     - Fixes a weakness in our not caching of proc generic dentries.
>     As shadow_proc uses a task struct to decided which dentry to return we can
>     go back later and fix the proc generic caching without modifying any code
>     that uses the shadow_proc method.
>     Signed-off-by: Eric W. Biederman <>
>     Cc: "Rafael J. Wysocki" <>
>     Cc: Pavel Machek <>
>     Cc: Pavel Emelyanov <>
>     Cc: "David S. Miller" <>
>     Cc: Ingo Molnar <>
>     Signed-off-by: Andrew Morton <>
>     Signed-off-by: Herbert Xu <>
> With the above patch, rpc.mountd is unable to open /proc/fs/nfsd/filehandle.
> Strace shows:
> open("/proc/fs/nfsd/filehandle", O_RDWR|O_LARGEFILE) = -1 ENOENT (No such file or directory)
> Without the above patch, /proc/fs/nfsd is populated with a number of files,
> including "filehandle".

Those files are actually in a separate filesystem (of type "nfsd") which
is supposed to be mounted on /proc/fs/nfsd/.   So that mount must have
failed in the bad case?  It's not immediately obvious to me what this
patch has to do with that.  Hm.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists