lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 6 Dec 2007 16:25:00 -0800
From:	Andrew Morton <>
To:	Marco Gatti <>
	Linus Torvalds <>,
	Greg KH <>, Thomas Gleixner <>,
	Ingo Molnar <>
Subject: Re: Bug: get EXT3-fs error Allocating block in system zone

On Tue, 04 Dec 2007 21:54:57 +0100
Marco Gatti <> wrote:

> Hello,
> I have a brand new Fujitsu-Siemens Celsius W360 pc with a FSC D2587-A1 
> motherboard. It has a intel q35 chipset. In bios I have the sata 
> controller in pure AHCI mode (legacy pata disabled). On windows 
> everthing works fine. So mem is ok, too, tested with memtest+ overnight. 
> No failures with hdd or motherboard on windows. There's latest avaiable 
> BIOS version on the machine.
> Specific system data see below.
> I first tried self compiled kernel 2.6.24-rc3 and now at the end 
> to have a stable version. I got compiled e1000 module for 
> network card onboard under latest gentoo stable version.
> I first got acpi failure on boot, pci=nommconf worked first time, than I 
> patched with q35.pci.patch from 
> and boot worked without 
> nommconf.

It disables PCI BARs during sizing.  ISTR Linus opining that this was the
wrong thing to do?

ISTR him having opinions on mmconfig too ;)

We should not require people to use obscure boot options to get their
machines working.

> But the effect is under every circumstances described above that I got 
> after an unspecific time EXT3-fs errors. I tried to use different 
> partitions, one for root and data, got errors on both.
> Dec  3 15:05:34 adira EXT3-fs error (device sdb4): ext3_new_block: 
> Allocating block in system zone - blocks from 74907667, length 1
> I tried different hard disks, different sizes of partitions, always the 
> same issue. I always saw that mem is fully cached (I have 8GB RAM!). 
> After that, the ext3 has severe faults fsck.ext3 repaired them, but an 
> amount of data was lost.
> I also tried with different file systems (reiserfs3, xfs), also kernel 
> trace errors, so I got back to ext3.
> Can't believe that it's a pure fs-error. Is it an ahci.c issue? Or a 
> problem with acpi and memory management?

At a guess I'd say the disk system is being bad.  it might be a hardware
failure too - it's a new system.

> Any ideas for fixing this?

Nope, sorry.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists