lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 07 Dec 2007 08:11:51 +0100
From:	Marco Gatti <>
To:	Andrew Morton <>
	Linus Torvalds <>,
	Greg KH <>, Thomas Gleixner <>,
	Ingo Molnar <>
Subject: Re: Bug: get EXT3-fs error Allocating block in system zone

Andrew Morton schrieb:
>> But the effect is under every circumstances described above that I got 
>> after an unspecific time EXT3-fs errors. I tried to use different 
>> partitions, one for root and data, got errors on both.
>> Dec  3 15:05:34 adira EXT3-fs error (device sdb4): ext3_new_block: 
>> Allocating block in system zone - blocks from 74907667, length 1
>> I tried different hard disks, different sizes of partitions, always the 
>> same issue. I always saw that mem is fully cached (I have 8GB RAM!). 
>> After that, the ext3 has severe faults fsck.ext3 repaired them, but an 
>> amount of data was lost.
>> I also tried with different file systems (reiserfs3, xfs), also kernel 
>> trace errors, so I got back to ext3.
>> Can't believe that it's a pure fs-error. Is it an ahci.c issue? Or a 
>> problem with acpi and memory management?
> At a guess I'd say the disk system is being bad.  it might be a hardware
> failure too - it's a new system.

I thought that first, too. I forgot to mention that I did a badblocks on 
the partitions and the two whole disks. No issues reported. I formated 
the disks several times and reinstalled the whole gentoo and compiled 
the kernel again more than one time (I tried 2.6.24-rc3 too) 'cause of 
the ext3 / other fs issues. I did dd if=/dev/zero of=... on the 
partitions and the whole disks. No issues of bad blocks. The strange 
thing is everything works fine under Windows XP x64 Prof. But I don't 
wanted to use that OS really... So I can't believe that's a hardware 
issue of the disks.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists