[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4772F972.7070802@zytor.com>
Date: Wed, 26 Dec 2007 17:01:38 -0800
From: "H. Peter Anvin" <hpa@...or.com>
To: Pavel Machek <pavel@....cz>
CC: Julia Lawall <julia@...u.dk>, tglx@...utronix.de,
viro@....linux.org.uk, linux-kernel@...r.kernel.org,
kernel-janitors@...r.kernel.org
Subject: Re: [PATCH 1/3] arch/x86: Use offsetof
Pavel Machek wrote:
>>
>> diff -u -p a/arch/x86/kernel/vm86_32.c b/arch/x86/kernel/vm86_32.c
>> --- a/arch/x86/kernel/vm86_32.c 2007-10-22 11:25:00.000000000 +0200
>> +++ b/arch/x86/kernel/vm86_32.c 2007-12-26 16:27:15.000000000 +0100
>> @@ -215,7 +215,9 @@ asmlinkage int sys_vm86old(struct pt_reg
>> ret = -EFAULT;
>> if (tmp)
>> goto out;
>> - memset(&info.vm86plus, 0, (int)&info.regs32 - (int)&info.vm86plus);
>> + memset(&info.vm86plus, 0,
>> + offsetof(struct kernel_vm86_struct, regs32) -
>> + offsetof(struct kernel_vm86_struct, vm86plus));
>
> I do not think this makes it more readable... (int) -> (char *) would
> make it portable and readable, AFAICT.
> Pavel
The right way to do it is:
memset(&info.vm86plus, 0, sizeof info.vm86plus);
-hpa
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists