[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.LFD.0.99999.0801041032430.4042@localhost.localdomain>
Date: Fri, 4 Jan 2008 10:42:17 +0100 (CET)
From: Thomas Gleixner <tglx@...utronix.de>
To: Andi Kleen <ak@...e.de>
cc: linux-kernel@...r.kernel.org
Subject: Re: [PATCH x86] [12/16] Optimize lock prefix switching to run less
frequently
On Thu, 3 Jan 2008, Andi Kleen wrote:
> This makes a significant difference in boot up performance on AMD SimNow!
> Also I expect it to be a little faster on native systems too because a smp
> switch does a lot of text_poke()s which each synchronize the pipeline.
Please run your patches through checkpatch.pl.
ERROR: use tabs not spaces
#48: FILE: arch/x86/kernel/alternative.c:360:
> +
> + /* Only switch to UP mode if we don't immediately boot others */
> + if (num_possible_cpus() == 1 || max_cpus == 0)
Shouldn't this be max_cpus <= 1 ?
> +extern unsigned int max_cpus;
I'm a bit wary about making max_cpus global. max_cpus is used all over
the place as a local variable name. Can we please rename it to
setup_max_cpus or something like that?
Thanks,
tglx
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists