[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20080116174706.GA27224@infradead.org>
Date: Wed, 16 Jan 2008 17:47:06 +0000
From: Christoph Hellwig <hch@...radead.org>
To: Dave Hansen <haveblue@...ibm.com>
Cc: Christoph Hellwig <hch@...radead.org>,
Andrew Morton <akpm@...ux-foundation.org>,
linux-kernel@...r.kernel.org, miklos@...redi.hu,
Bryn Reeves <breeves@...hat.com>,
Alasdair G Kergon <agk@...hat.com>
Subject: Re: [PATCH 04/27] kill filp_open()
On Wed, Jan 16, 2008 at 09:41:12AM -0800, Dave Hansen wrote:
> On Wed, 2008-01-16 at 17:10 +0000, Christoph Hellwig wrote:
> >
> > But ultimatively I think we should remove this silly renaming from
> > the patch. It doesn't help the goal and just created churn, so please
> > rename open_namei back to do_filp_open for now and put filp_open back.
>
> It wasn't really a rename. More that I ended up moving everything
> useful the filp_open() did to other functions, so I didn't see the need
> to keep around a stub like this:
>
> struct file *filp_open(const char *filename, int flags, int mode)
> {
> return open_namei(AT_FDCWD, filename, flags, mode);
> }
>
> It would be trivial to add this stub back, though.
Well, it was a name from the caller point of view :) You basically
merged do_filp_open and open_namei. Given that open_namei was an
internal helper only used by do_filp_open it seems quite sensible to
keep the existing do_filp_open user interface and call the merged
function do_filp_open. Especially as filp_open is a quite descriptive
name of what we're doing here - open the pathname and return a file
pointer for it.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists