lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 21 Jan 2008 09:21:32 +0100
From:	Joe <>
To:	Rafael Sisto <>
CC:	Linux kernel <>
Subject: Re: create a file in kernel mode. help please!

Hi Rafael.

Probably you haven't got any answers yet because you should NEVER EVER 
(i repeat: NEVER EVER, not even in college projects) go for file I/O in 
the kernel. You might want to think the whole thing over one or two 
times, i think.

If it comes to you that it is absolutely necessary (i repeat again: 
ABSOLUTELY NECESSARY, like a solution to feed the world) then you might 
google for some ancient FAQ of Greg (K-H) (i think he was) where he 
tries to give a little more details about this kind of problem, and also 
gives a possible solution, IIRC. Sorry that i don't remember the exact 
page/adress anymore, for i intend never to look at it again.


Rafael Sisto schrieb:
> Hi there,
> obviously this is a newbie question, but I couldn't find any
> documentation on how to do it.. I tried several ways but couldnt do
> it.
> I designed a system call, so a user will call it, and a new file will
> be created ('/tmp/filexx'). After that, I have another system call,
> that will map the file into the maps of the user process. The idea is
> the same as IPC...
> I managed to create the file with this function (in the first system call):
>         fd = filp_open(path, O_CREAT | O_RDWR , 777);
> After that, the user will call another system call, and it will map
> this file to the process maps.
> something like this:
>          filp_open(route, O_RDWR,0 );
>          do_mmap(fp, 0, tamano, PROT_READ | PROT_WRITE | PROT_EXEC,
> After I call the second system call, the user tries to access the
> memory, but gets the message "Bus Error".
> I tried to manually create a file with vi, and then use the second
> system call, and worked perfectly. I could use the shared memory
> without problems.
> The problems seems to be in the first system call (with filp_open),
> when I try to create a new file... Can somebody suggest me something,
> on how I could fix this issue?? It is very important because it is for
> a college projects.
> Greetings, and thanks in advance for the answers.
> Rafael Sisto - Uruguay.-
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to
> More majordomo info at
> Please read the FAQ at

Sepp "ZaP" Holzmayr

please reply to:

watch out for:
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists