[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <Pine.LNX.4.64.0801271428390.9257@anakin>
Date: Sun, 27 Jan 2008 14:29:31 +0100 (CET)
From: Geert Uytterhoeven <geert@...ux-m68k.org>
To: Linus Torvalds <torvalds@...ux-foundation.org>,
Andrew Morton <akpm@...ux-foundation.org>,
Bartlomiej Zolnierkiewicz <bzolnier@...il.com>,
Sergei Shtylyov <sshtylyov@...mvista.com>
cc: Linux/m68k <linux-m68k@...r.kernel.org>,
Linux Kernel Development <linux-kernel@...r.kernel.org>
Subject: [PATCH] Atari Falcon IDE: Add missing hwif variable
Atari Falcon IDE: Add missing hwif variable
Commit cbb010c180294a5242a7681555c28737d9dd26ab
ide: drop 'initializing' argument from ide_register_hw()
* Rename init_hwif_data() to ide_init_port_data() and export it.
* For all users of ide_register_hw() with 'initializing' argument set
hwif->present and hwif->hold are always zero so convert these host
drivers to use ide_find_port()+ide_init_port_data()+ide_init_port_hw()
instead (also no need for init_hwif_default() call since the setup
done by it gets over-ridden by ide_init_port_hw() call).
* Drop 'initializing' argument from ide_register_hw().
introduced the usage of a hwif variable, but forgot to declare the actual
variable.
Signed-off-by: Geert Uytterhoeven <geert@...ux-m68k.org>
Cc: Bartlomiej Zolnierkiewicz <bzolnier@...il.com>
Cc: Sergei Shtylyov <sshtylyov@...mvista.com>
---
drivers/ide/legacy/falconide.c | 1 +
1 file changed, 1 insertion(+)
--- a/drivers/ide/legacy/falconide.c
+++ b/drivers/ide/legacy/falconide.c
@@ -66,6 +66,7 @@ static int __init falconide_init(void)
{
if (MACH_IS_ATARI && ATARIHW_PRESENT(IDE)) {
hw_regs_t hw;
+ ide_hwif_t *hwif;
printk(KERN_INFO "ide: Falcon IDE controller\n");
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@...ux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists