lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Fri, 1 Feb 2008 17:21:39 +0100
From:	Ingo Molnar <mingo@...e.hu>
To:	Willy Tarreau <w@....eu>
Cc:	Paolo Ciarrocchi <paolo.ciarrocchi@...il.com>,
	Linux Kernel <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 3/7] X86: Fix trailing statements should be on next line


* Willy Tarreau <w@....eu> wrote:

> Hi Paolo,
> 
> On Tue, Jan 29, 2008 at 12:07:44AM +0100, Paolo Ciarrocchi wrote:
> > Fix trailing statements should be on next line
> 
> > -if ( partial_status & SW_C3 )          printk("SW: condition bit 3\n");
> > -if ( partial_status & SW_C2 )          printk("SW: condition bit 2\n");
> > -if ( partial_status & SW_C1 )          printk("SW: condition bit 1\n");
> > -if ( partial_status & SW_C0 )          printk("SW: condition bit 0\n");
> > -if ( partial_status & SW_Summary )     printk("SW: exception summary\n");
> > -if ( partial_status & SW_Stack_Fault ) printk("SW: stack fault\n");
> > -if ( partial_status & SW_Precision )   printk("SW: loss of precision\n");
> > -if ( partial_status & SW_Underflow )   printk("SW: underflow\n");
> > -if ( partial_status & SW_Overflow )    printk("SW: overflow\n");
> > -if ( partial_status & SW_Zero_Div )    printk("SW: divide by zero\n");
> > -if ( partial_status & SW_Denorm_Op )   printk("SW: denormalized operand\n");
> > -if ( partial_status & SW_Invalid )     printk("SW: invalid operation\n");
> 
> > +if ( partial_status & SW_Backward )
> > +printk("SW: backward compatibility\n");
> > +if ( partial_status & SW_C3 )
> > +printk("SW: condition bit 3\n");
> > +if ( partial_status & SW_C2 )
> > +printk("SW: condition bit 2\n");
> > +if ( partial_status & SW_C1 )
> > +printk("SW: condition bit 1\n");
> > +if ( partial_status & SW_C0 )
> > +printk("SW: condition bit 0\n");
> > +if ( partial_status & SW_Summary )
> > +printk("SW: exception summary\n");
> > +if ( partial_status & SW_Stack_Fault )
> > +printk("SW: stack fault\n");
> > +if ( partial_status & SW_Precision )
> > +printk("SW: loss of precision\n");
> > +if ( partial_status & SW_Underflow )
> > +printk("SW: underflow\n");
> > +if ( partial_status & SW_Overflow )
> > +printk("SW: overflow\n");
> > +if ( partial_status & SW_Zero_Div )
> > +printk("SW: divide by zero\n");
> > +if ( partial_status & SW_Denorm_Op )
> > +printk("SW: denormalized operand\n");
> > +if ( partial_status & SW_Invalid )
> > +printk("SW: invalid operation\n");
> >  #endif /* DEBUGGING */
> 
> Well, IMHO, the code was more readable and checkable in the initial 
> version. I think this is one example of exceptions where code 
> appearance is more important than style correctness.

definitely so. The rule of thumb is: if in doubt, use your human taste. 
Does it 'look' better? If not, dont do the change.

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ