[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20080203103213.GC20810@uranus.ravnborg.org>
Date: Sun, 3 Feb 2008 11:32:13 +0100
From: Sam Ravnborg <sam@...nborg.org>
To: "A.E.Lawrence" <lawrence_a_e@...world.com>,
Ingo Molnar <mingo@...e.hu>
Cc: linux-kernel@...r.kernel.org
Subject: [PATCH] x86: restore correct module name for apm
The apm module were renamed to apm_32 during the merge of 32 and 64 bit x86 which
is unfortunate.
As apm is 32 bit specific we like to keep the _32 in the filename
but the module should be named apm.
Fix this in the Makefile.
Reported by "A.E.Lawrence" <lawrence_a_e@...world.com>
Signed-off-by: Sam Ravnborg <sam@...nborg.org>
Cc: Cc: Ingo Molnar <mingo@...e.hu>
Cc: Thomas Gleixner <tglx@...utronix.de>
Cc: "H. Peter Anvin" <hpa@...or.com>
Cc: "A.E.Lawrence" <lawrence_a_e@...world.com>
---
build tested only but obviously correct.
Sam
diff --git a/arch/x86/kernel/Makefile b/arch/x86/kernel/Makefile
index 6f81300..f080635 100644
--- a/arch/x86/kernel/Makefile
+++ b/arch/x86/kernel/Makefile
@@ -37,7 +37,8 @@ obj-$(CONFIG_X86_MSR) += msr.o
obj-$(CONFIG_X86_CPUID) += cpuid.o
obj-$(CONFIG_MICROCODE) += microcode.o
obj-$(CONFIG_PCI) += early-quirks.o
-obj-$(CONFIG_APM) += apm_32.o
+apm-y := apm_32.o
+obj-$(CONFIG_APM) += apm.o
obj-$(CONFIG_X86_SMP) += smp_$(BITS).o smpboot_$(BITS).o tsc_sync.o
obj-$(CONFIG_X86_32_SMP) += smpcommon_32.o
obj-$(CONFIG_X86_64_SMP) += smp_64.o smpboot_64.o tsc_sync.o
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists