lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 8 Feb 2008 13:51:54 -0800
From:	Andrew Morton <akpm@...ux-foundation.org>
To:	Harvey Harrison <harvey.harrison@...il.com>
Cc:	torvalds@...ux-foundation.org, viro@...IV.linux.org.uk,
	linux-kernel@...r.kernel.org, mingo@...e.hu
Subject: Re: [PATCH] fix sparse warning from include/linux/mmzone.h

On Thu, 07 Feb 2008 12:52:23 -0800
Harvey Harrison <harvey.harrison@...il.com> wrote:

> include/linux/mmzone.h:640:22: warning: potentially expensive pointer subtraction
> 
> The code in question was doing a pointer subtraction to find the index of
> the zone argument in the node_zones array.  This essentially boils down to:
> 
> ((unsigned long)zone - (unsigned long)zone->zone_pgdat->node_zones)/sizeof(struct zone)
> 
> Which can be expensive if struct zone is not a power of two.  Instead, just
> calculate the offsets rather than the index in the array.
> 
> Signed-off-by: Harvey Harrison <harvey.harrison@...il.com>
> ---
> This shows up > 30 times in an x86 allyesconfig, would be nice to get
> rid of it and makes the code a little more efficient.  I believe this
> is correct, unless there is a subtlety I have missed.
> 
>  include/linux/mmzone.h |    9 ++++++---
>  1 files changed, 6 insertions(+), 3 deletions(-)
> 
> diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
> index 8d8d197..cb07758 100644
> --- a/include/linux/mmzone.h
> +++ b/include/linux/mmzone.h
> @@ -637,9 +637,12 @@ static inline int is_normal_idx(enum zone_type idx)
>  static inline int is_highmem(struct zone *zone)
>  {
>  #ifdef CONFIG_HIGHMEM
> -	int zone_idx = zone - zone->zone_pgdat->node_zones;
> -	return zone_idx == ZONE_HIGHMEM ||
> -		(zone_idx == ZONE_MOVABLE && zone_movable_is_highmem());
> +	const int highmem_off = ZONE_HIGHMEM * sizeof(*zone);
> +	const int movable_off = ZONE_MOVABLE * sizeof(*zone);
> +
> +	int zone_off = (unsigned long)zone - (unsigned long)zone->zone_pgdat->node_zones;
> +	return zone_off == highmem_off ||
> +		(zone_off == movable_off && zone_movable_is_highmem());
>  #else
>  	return 0;
>  #endif
> -- 

hrm.  For my i386 build (and that's where CONFIG_HIGHMEM really matters)
this patch makes mm/page_alloc.o six bytes larger, and I don't think the
change did much for readability.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ