lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 11 Feb 2008 15:24:05 +0100
From:	Andi Kleen <ak@...e.de>
To:	Peter Zijlstra <a.p.zijlstra@...llo.nl>
Cc:	Ingo Molnar <mingo@...e.hu>, ying.huang@...el.com,
	tglx@...utronix.de, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] [6/8] Account overlapped mappings in end_pfn_map

On Monday 11 February 2008 15:16:31 Peter Zijlstra wrote:
> 
> On Mon, 2008-02-11 at 14:27 +0100, Andi Kleen wrote:
> 
> > Ok patch with hungarized variables appended.
> 
> > -static void __meminit
> > +static unsigned long __meminit
> >  phys_pmd_update(pud_t *pud, unsigned long address, unsigned long end)
> >  {
> > +	unsigned long true_end;
> >  	pmd_t *pmd = pmd_offset(pud, 0);
> >  	spin_lock(&init_mm.page_table_lock);
> > -	phys_pmd_init(pmd, address, end);
> > +	true_end = phys_pmd_init(pmd, address, end);
> >  	spin_unlock(&init_mm.page_table_lock);
> >  	__flush_tlb_all();
> > +	return true_end;
> >  }
> 
> Just for the record, Hungarian notation would have it like:
> 
>   ulTrueEnd

_pfn is variant of hungarian notation (just postfix instead of prefix); 
that is why I referred to it. 

Admittedly it was a little unfair pun with Ingo, but he really 
asked for it  in this case :-)


> http://en.wikipedia.org/wiki/Hungarian_notation
> 
> And the kernel doesn't do that, to wit (from Documentation/CodingStyle):
> 
>  Linus Torvalds (against systems Hungarian): Encoding the type of a
> function into the name (so-called Hungarian notation) is brain damaged -
> the compiler knows the types anyway and can check those, and it only
> confuses the programmer.

xxx_pfn is exactly that. 

BTW Coding style also recommends to use short variable names inside 
functions. Ingo asked me actually to violate that:

"
LOCAL variable names should be short, and to the point.  If you have
some random integer loop counter, it should probably be called "i".
Calling it "loop_counter" is non-productive, if there is no chance of it
being mis-understood.  Similarly, "tmp" can be just about any type of
variable that is used to hold a temporary value.
"

I used r for result in this case which is 100% conform to coding style.

-Andi (trying to exit this thread) 
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ