[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20080309205132.GA9021@elte.hu>
Date: Sun, 9 Mar 2008 21:51:32 +0100
From: Ingo Molnar <mingo@...e.hu>
To: Alexander van Heukelum <heukelum@...tmail.fm>
Cc: Alexander van Heukelum <heukelum@...lshack.com>,
Thomas Gleixner <tglx@...utronix.de>,
"H. Peter Anvin" <hpa@...or.com>,
LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] x86: Change x86 to use generic find_next_bit
* Alexander van Heukelum <heukelum@...tmail.fm> wrote:
> > > #define BITOP_WORD(nr) ((nr) / BITS_PER_LONG)
> > > +#undef find_next_bit
> > > +#undef find_next_zero_bit
> >
> > this bit looks weird - did you need it for testing?
>
> Worse, it's needed to get x86_64 to compile.
>
> They are defined in include/asm-x86/bitops_64.h (which gets included).
> They are used to optimize the case where the bitmap size is known at
> compile time and not larger than BITS_PER_LONG. Undeffing them here is
> the easiest way to get things to compile, here.
ok - but this needs to be solved in a cleaner way. That build-time
optimization needs to be pushed into generic code so that 32-bit x86 and
other architectures can make use of it as well. The lib/find_next_bit.c
functions should be named __find_next_bit() or so.
Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists