lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 12 Mar 2008 09:54:26 -0700
From:	Harvey Harrison <harvey.harrison@...il.com>
To:	Michael Buesch <mb@...sch.de>
Cc:	Andrew Morton <akpm@...ux-foundation.org>,
	LKML <linux-kernel@...r.kernel.org>,
	Alan Cox <alan@...rguk.ukuu.org.uk>,
	Jeff Garzik <jeff@...zik.org>,
	Bartlomiej Zolnierkiewicz <bzolnier@...il.com>,
	Mauro Carvalho Chehab <mchehab@...radead.org>
Subject: Re: [PATCH 1/6] kernel: add clamp(), clamp_t() and clamp_val()
	macros

On Wed, 2008-03-12 at 16:13 +0100, Michael Buesch wrote:
> So why not call it clamp_const()?
> One could even use __builtin_constant_p() and make clamp() use
> either clamp_const() or clamp_nonconst() from above automagically.
> I'd prefer that.

Did you mean something like this?  No more clamp_val, just clamp and
clamp_t.  clamp_t forces all the types, clamp looks at the min and max
args, and if they are constants, uses the type of val instead.  If not
a constant, the strict typechecking is done.

From: Harvey Harrison <harvey.harrison@...il.com>
Subject: [PATCH] kernel: add clamp(), clamp_t() macros

Adds macros similar to min/max/min_t/max_t.

Also, change the variable names used in the min/max macros to
avoid shadowed variable warnings when min/max min_t/max_t are
nested.

Small formatting changes to make all the macros have a similar
form.

Signed-off-by: Harvey Harrison <harvey.harrison@...il.com>
---
 include/linux/kernel.h |   68 +++++++++++++++++++++++++++++++++++------------
 1 files changed, 50 insertions(+), 18 deletions(-)

diff --git a/include/linux/kernel.h b/include/linux/kernel.h
index 2df44e7..0d4cb5f 100644
--- a/include/linux/kernel.h
+++ b/include/linux/kernel.h
@@ -335,33 +335,65 @@ static inline int __attribute__ ((format (printf, 1, 2))) pr_debug(const char *
 #endif /* __LITTLE_ENDIAN */
 
 /*
- * min()/max() macros that also do
+ * min()/max()/clamp() macros that also do
  * strict type-checking.. See the
  * "unnecessary" pointer comparison.
  */
-#define min(x,y) ({ \
-	typeof(x) _x = (x);	\
-	typeof(y) _y = (y);	\
-	(void) (&_x == &_y);		\
-	_x < _y ? _x : _y; })
-
-#define max(x,y) ({ \
-	typeof(x) _x = (x);	\
-	typeof(y) _y = (y);	\
-	(void) (&_x == &_y);		\
-	_x > _y ? _x : _y; })
+#define min(x, y) ({				\
+	typeof(x) _min1 = (x);			\
+	typeof(y) _min2 = (y);			\
+	(void) (&_min1 == &_min2);		\
+	_min1 < _min2 ? _min1 : _min2; })
+
+#define max(x, y) ({				\
+	typeof(x) _max1 = (x);			\
+	typeof(y) _max2 = (y);			\
+	(void) (&_max1 == &_max2);		\
+	_max1 > _max2 ? _max1 : _max2; })
+
+#define clamp(val, min, max) ({				\
+	typeof(val) __val = (val);			\
+							\
+	if (__builtin_constant_p(min)) {		\
+		typeof(val) __min = (min);		\
+		__val = __val < __min ? __min: __val;	\
+	} else {					\
+		typeof(min) __min = (min);		\
+		(void) (&__val == &__min);		\
+		__val = __val < __min ? __min: __val;	\
+	}						\
+							\
+	if (__builtin_constant_p(max)) {		\
+		typeof(val) __max = (max);		\
+		__val > __max ? __max: __val;		\
+	} else {					\
+		typeof(max) __max = (max);		\
+		(void) (&__val == &__max);		\
+		__val > __max ? __max: __val;		\
+	} })
 
 /*
  * ..and if you can't take the strict
  * types, you can specify one yourself.
  *
- * Or not use min/max at all, of course.
+ * Or not use min/max/clamp at all, of course.
  */
-#define min_t(type,x,y) \
-	({ type __x = (x); type __y = (y); __x < __y ? __x: __y; })
-#define max_t(type,x,y) \
-	({ type __x = (x); type __y = (y); __x > __y ? __x: __y; })
-
+#define min_t(type, x, y) ({			\
+	type __min1 = (x);			\
+	type __min2 = (y);			\
+	__min1 < __min2 ? __min1: __min2; })
+
+#define max_t(type, x, y) ({			\
+	type __max1 = (x);			\
+	type __max2 = (y);			\
+	__max1 > __max2 ? __max1: __max2; })
+
+#define clamp_t(type, val, min, max) ({		\
+	type __val = (val);			\
+	type __min = (min);			\
+	type __max = (max);			\
+	__val = __val < __min ? __min: __val;	\
+	__val > __max ? __max: __val; })
 
 /**
  * container_of - cast a member of a structure out to the containing structure
-- 
1.5.4.4.592.g32d4c



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ