[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <1205343249.8603.23.camel@brick>
Date: Wed, 12 Mar 2008 10:34:09 -0700
From: Harvey Harrison <harvey.harrison@...il.com>
To: Michael Buesch <mb@...sch.de>
Cc: Andrew Morton <akpm@...ux-foundation.org>,
LKML <linux-kernel@...r.kernel.org>,
Alan Cox <alan@...rguk.ukuu.org.uk>,
Jeff Garzik <jeff@...zik.org>,
Bartlomiej Zolnierkiewicz <bzolnier@...il.com>,
Mauro Carvalho Chehab <mchehab@...radead.org>
Subject: Re: [PATCH 1/6] kernel: add clamp(), clamp_t() and clamp_val()
macros
On Wed, 2008-03-12 at 18:20 +0100, Michael Buesch wrote:
> On Wednesday 12 March 2008 17:54:26 Harvey Harrison wrote:
> > On Wed, 2008-03-12 at 16:13 +0100, Michael Buesch wrote:
> > > So why not call it clamp_const()?
> > > One could even use __builtin_constant_p() and make clamp() use
> > > either clamp_const() or clamp_nonconst() from above automagically.
> > > I'd prefer that.
> >
> > Did you mean something like this? No more clamp_val, just clamp and
> > clamp_t. clamp_t forces all the types, clamp looks at the min and max
> > args, and if they are constants, uses the type of val instead. If not
> > a constant, the strict typechecking is done.
>
> > +#define clamp(val, min, max) ({ \
> > + typeof(val) __val = (val); \
> > + \
> > + if (__builtin_constant_p(min)) { \
> > + typeof(val) __min = (min); \
> > + __val = __val < __min ? __min: __val; \
> > + } else { \
> > + typeof(min) __min = (min); \
> > + (void) (&__val == &__min); \
> > + __val = __val < __min ? __min: __val; \
> > + } \
> > + \
> > + if (__builtin_constant_p(max)) { \
> > + typeof(val) __max = (max); \
> > + __val > __max ? __max: __val; \
> > + } else { \
> > + typeof(max) __max = (max); \
> > + (void) (&__val == &__max); \
> > + __val > __max ? __max: __val; \
> > + } })
>
> Yeah, something like that.
> Does returning of the value work over an indentation level, too?
> I dunno this detail of the language.
> But I'd prefer the following for readability anyway:
>
> + if (__builtin_constant_p(max)) { \
> + typeof(val) __max = (max); \
> + __val = __val > __max ? __max: __val; \
> + } else { \
> + typeof(max) __max = (max); \
> + (void) (&__val == &__max); \
> + __val = __val > __max ? __max: __val; \
> + }
> + __val; })
Yeah, that is better. (and even works).
Harvey
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists