[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <47DA93D0.4050708@goop.org>
Date: Fri, 14 Mar 2008 08:03:44 -0700
From: Jeremy Fitzhardinge <jeremy@...p.org>
To: Jan Beulich <jbeulich@...ell.com>
CC: linux-kernel@...r.kernel.org
Subject: Re: [PATCH] x86: simplify sync_test_bit()
Jan Beulich wrote:
> There really is no need for a redundant implementation here, just keep
> the alternative name for allowing consumers to use consistent naming.
>
> Signed-off-by: Jan Beulich <jbeulich@...ell.com>
>
> --- a/include/asm-x86/sync_bitops.h
> +++ b/include/asm-x86/sync_bitops.h
> @@ -130,26 +130,7 @@ static inline int sync_test_and_change_b
> return oldbit;
> }
>
> -static __always_inline int sync_constant_test_bit(int nr, const volatile unsigned long *addr)
> -{
> - return ((1UL << (nr & 31)) &
> - (((const volatile unsigned int *)addr)[nr >> 5])) != 0;
> -}
> -
> -static inline int sync_var_test_bit(int nr, const volatile unsigned long * addr)
> -{
> - int oldbit;
> -
> - __asm__ __volatile__("btl %2,%1\n\tsbbl %0,%0"
> - :"=r" (oldbit)
> - :"m" (ADDR),"Ir" (nr));
> - return oldbit;
> -}
> -
> -#define sync_test_bit(nr,addr) \
> - (__builtin_constant_p(nr) ? \
> - sync_constant_test_bit((nr),(addr)) : \
> - sync_var_test_bit((nr),(addr)))
> +#define sync_test_bit test_bit
Hm,
#define sync_test_bit(nr, addr) test_bit(nr, addr)
would be better, but seems reasonable to me. Or even an inline for
consistency.
J
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists